TechSpot

Windows 8.1 multi monitor

By Deltree
Mar 30, 2015
Post New Reply
  1. I have an E3D420VX 3DTV at 1080p which I use as my main desktop plugged into my (sad) HD 5770 GPU. I also have an ASUS VK426 1080p for my second screen plugged into HDMI on MSI Z97 Gaming 7 mobo, using the latest Intel drivers from Intel Driver Update Utility. With Windows 7 it worked flawlessly, now I use Windows 8.1 and although I can see my mouse cursor clearly on the second screen all other visuals are totally borked. Can anyone help me fix this? I have the 5th episode of my youtube show due in 2 days! Could really use my second screen. Ugh!

    Also, my GPU and Intel drivers are the latest for windows 8.1-64bit, and I did enable the integrated graphics in my bios and applied the full GB of ram to it as well, same as I did with Windows 7.
     
    Last edited: Mar 30, 2015
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Still having problems?
     
  3. Deltree

    Deltree TS Enthusiast Topic Starter Posts: 27

    Yes ugh
     
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    So the monitor connected to the motherboard's integrated graphics port is clear, and the one connected to the HD 5770 GPU is messed up?
     
  5. Deltree

    Deltree TS Enthusiast Topic Starter Posts: 27

    Other way around. HD 5770, for being a hideous chunk of pure whack in my otherwise beast-*** system, is working fine. The integrated graphics stopped working when I switched to Windows 8.1 and installed the latest drivers with Intel Driver Update Utility 2.0. I can see my cursor on the Intel run screen, but everything else on that display is just crazy lines of color that react to things happening and nothing useful.
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...