Windows XP Home Edition Service Pack 2...

By clp86rom
Oct 11, 2005
Topic Status:
Not open for further replies.
  1. Hi,

    I have this computer that has windows xp home edition on it and i installed the windows service pack 2 update which went okay but after installing it my cd and dvd drives disappeared from my computer. Under device manager… the computer sees the two drivers there but they have a question mark or exclamation mark I forgot which right now. What do I need to fix this situation. Can anyone please let me out. I need this fixed fast.
  2. iss

    iss TechSpot Chancellor Posts: 2,896

    in device manager go to "IDE ATA\ATAPI controllers" uninstall the primary and secondary IDE channels and reboot. Windows will automatically reinstall them on boot up and this should fix your problem.
  3. clp86rom

    clp86rom Newcomer, in training Topic Starter Posts: 20

    thanks a lot. i will try it out.
  4. clp86rom

    clp86rom Newcomer, in training Topic Starter Posts: 20

    it is not working. can anyone help me out really fast? please.
  5. iss

    iss TechSpot Chancellor Posts: 2,896

    you could try physically uninstalling the drives. unplug the computer and hold down the power button to get rid if any residual power in the system. then unplug the power and the IDE connection cables from both drives then boot up. then shut down and follow a reverse process to hook the drives back up. then power up and see if windows recognizes and installs the drives.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.