XFX Motherboard Problem

By NaOH
Aug 31, 2008
Topic Status:
Not open for further replies.
  1. I have a XFX nforce 780i motherboard and it will not post, all it does is sit there with the FF (Boot) message. It started after I loaded the system defaults in my bios. I have tried taking everything out my physx card, GTX 280, and hard disks, leaving only my cpu, memory, psu, and water cooling system. As well I have check the little button cell on the board to see if it was dead and hit the rest button multiple times but nothing will happen. Right now I think my motherboard is just toast. I need help ASAP!!!


    XFX nforce 780i socket 775
    Intel E8400 3.0Ghz
    XFX GTX 280 1GB
    Thermaltake 1200W psu
    Ageia Physx processor
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,732   +156

    Replace the motherboard...
  3. EXCellR8

    EXCellR8 The Conservative Posts: 2,278

    Those XFX boards are problematic... especially the 780i chipset. It's a really good chance that you just have a bad one there. I would get in touch with XFX's tech support, which is actually pretty good, and let them know exactly what the board is doing. Tell them what you've tried, and that you are no computer noob, and they'll probably set up an RMA. I think there have been a lot of problems with these boards; perhaps XFX should stick to graphics cards...
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.