TechSpot

XIII nVidia driver issue

By rliu
May 6, 2005
Topic Status:
Not open for further replies.
  1. My copy of XIII works with the nVidia driver 66.83 but not with the latest v70, can anyone help me on why that is?
  2. Didou

    Didou Bowtie extraordinair! Posts: 5,899

    There is a patch available for the game (LINK), have you installed it already ?
  3. rliu

    rliu Newcomer, in training Topic Starter Posts: 78

    Yeah. It seems like only the ver.66 driver works.
  4. Didou

    Didou Bowtie extraordinair! Posts: 5,899

    I'm playing it with the 71.89 myself so I'm not sure the nVidia drivers are the problem. I do get weird slowdowns as if there was some "bullet-time" activated, it doesn't seem like it's the VGA card lagging.

    What seems to be the problem when you launch the game ?
  5. rliu

    rliu Newcomer, in training Topic Starter Posts: 78

    The start up screen with the Ubisoft logo freezes up and sometimes doesn't even show up, i.e. it's just a black screen I see, maybe it depends on what Geforce card you have as well, cos ver.70 is really aimed at Geforce 6 cards, so it does nothing to improve FX series or 1, 2, 3 and 4
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.