2 Routers, 1 Network

By wmoore029
Jul 3, 2009
Topic Status:
Not open for further replies.
  1. Hi

    I have about lost all my hair. I am trying to follow instructions to the T, and I am getting stuck!

    Here is what I am wanting to do. We have a BlueRay and TV that uses internet features, and the TV has to have a wired and Blueray is cheaper to be wired, than getting their wireless adapter.. anway

    Instead of buying a switch I still have my old router (WRT54G V5) (one I am gonna put in living room)

    My new Router is WRT110.

    I have the old router set as 192.168.1.2 and the WRT110 192.168.1.1
    It is setup on the LAN ports on both, not WAN.
    Block Anonymous Internet Requests is "unchecked" on the old router.
    DHCP is disabled on the (old router)

    I can access both routers config pages from the main computer.

    But the laptop, that is attached to the old router, cannot do anthing, no config page nor internet. I have manually tried doing an ip, gateway in Windows, but thats a no go.

    I am at a loss please help! Thanks in advance
  2. jobeard

    jobeard TS Ambassador Posts: 13,282   +280

    disable DHCP on the wireless and leave only the Wired router with DHCP.

    wire them in this sequence
    Code:
    modem---wired---(lan side)wireless....
    any system can be wired to either router and the wired router will control all ip address assignments

    the address of the wireless router does not matter as it will do no routing --
    it's acting just like a switch.
  3. wmoore029

    wmoore029 Newcomer, in training Topic Starter

    thanks..

    thats how I have it set up now, only problem is I cannot connect wireless or by cat5 on the 2nd router.
  4. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    It sounds like everything is setup correctly.

    As long as you've disabled DHCP on the second router, configured each router to have a unique IP and have connected the second router through the *only* the LAN ports.. that's perfect.

    This is straw grabbing, but perhaps your router isn't working as intended because of a firmware bug. You can look into updating the firmware or replacing it with a custom firmware such as Tomato or DD-WRT and try again. I'm out of ideas after that, though.

    Assuming the information you've provided is correct, your really only left with the option of buying a new switch.
  5. wmoore029

    wmoore029 Newcomer, in training Topic Starter

    i upgraded firmware.. that did not help. It would not let me use ones you suggested..
    kept saying failed.

    I did notice something.. not sure if this is it.. the main router is not assining an ip to the old router.
  6. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    That's OK -- that is expected behavior. Besides, you should have the IP address specified manually. Routers like that can hand out IP address, but cannot lease IPs from other DHCP servers as they do not have DHCP client functionality.

    And actually, the IP address of the old router doesn't matter anyway. It can be absolutely anything. The only exception is neither router can have the same IP address, or you'll have some serious issues.
  7. wmoore029

    wmoore029 Newcomer, in training Topic Starter

    i am gonna end up buying a hub lol, this is not wanting to work for me, not sure what iam doing wrong.
  8. subcan

    subcan Newcomer, in training Posts: 70

    two routers - one as 'wireless switch'

    wmoore029,
    I may have an answer for you. I am in Iraq and have a satellite internet network for 23 soldiers. It is a little more complex than what you want to do, but the principles are much the same. I have several wireless routers connected in the network. It took me a little work to figure out, but it has worked flawlessly for entire deployment.

    from your original post:
    I have the old router set as 192.168.1.2 and the WRT110 192.168.1.1
    It is setup on the LAN ports on both, not WAN.
    Block Anonymous Internet Requests is "unchecked" on the old router.
    DHCP is disabled on the (old router)


    I will assume:
    1) that you are connecting to the internet via a cable/dsl modem.
    2) that you are connecting to the 'internet' port (back of WRT110 router) from the cable/dsl modem.
    3) that any other ethernet connections are being made from the WRT110.

    The WRT110 router:
    In "Internet setup" section you need to configure "Internet Connection Type" to "Automatic Configuration - DHCP"
    Set the "Router IP" to 192.168.1.1 and the subnet to 255.255.255.0.
    I would set the -- "Starting IP Address" to 192.168.1.2
    I would set the -- "Maximum Number of DHCP Users:" to 50 or less depending on how many IP addresses you wish to have router give out.
    Then from "Ethernet Port 1" on the back of the router run a CAT5e cable to the "Ethernet Port 1" on the back of the old WRT54G router. ***It is critical that you do not connect to the Internet port on this router***

    The WRT54G router:
    In "Internet setup" section you need to configure "Internet Connection Type" to "Automatic Configuration - DHCP"
    I would set the "Router IP" to 192.168.1.249 (or something outside of the "Maximum Number of DHCP Users:" that you set up on the WRT110 router) and the subnet to 255.255.255.0.

    Other than this you do not have to change any of the other settings. Leave everything else as it is after a hard reset.

    This should also let you connect to the three remaining ethernet ports on the back of the WRT54G router.

    ***I would recommend putting a piece of electrical tape over the "internet" port on the WRT54G router also. This will prevent someone else from thinking that they can fix some other problem down the road. It happens...***

    I have included an "clipping of the settings from one of my routers" as an example of how WRT54G router needs to be set up. Using linksys is definitely a plus. They are the easiest to configure.

    Make sure to use WPA2 security with a "strong" phrase... something with letters, numbers, and special characters.

    This should do the trick for you.

    I hope it helps.

    Subcan

    ps. I hope that this possible remedy to your problem is not too confusing. I tried to word it with adequate detail. Sorry if it is. I would be happy to clarify...

    Attached Files:

  9. wmoore029

    wmoore029 Newcomer, in training Topic Starter

    thanks, do I still disable dhcp on 2nd router
  10. wmoore029

    wmoore029 Newcomer, in training Topic Starter

    duh just saw pic..

    ok still cannot connect thru 2nd router with those settings.

    Computer hardwired into 2nd router
  11. subcan

    subcan Newcomer, in training Posts: 70

    wmoore029,

    I have to go to work for a couple of hours. When I get back I will set up this configuration with a couple of my spare wireless routers, to see where the possible problem is.

    Just make sure that you are connected via Cat5e from ethernet port 1 to ethernet port 1 of both routers. The 2nd router does not use the 'internet' port.

    I will send my findings to you later unless I hear from you that you have it working.

    Good luck,
    Subcan
     
  12. subcan

    subcan Newcomer, in training Posts: 70

    I will test the configuration with my routers.

    wmoore029,

    I have to go to work for a couple of hours. When I get back I will set up this configuration with a couple of my spare wireless routers, to see where the possible problem is.

    Just make sure that you are connected via Cat5e from ethernet port 1 to ethernet port 1 of both routers. The 2nd router does not use the 'internet' port.

    I would also do a hard reset of both routers to original configuration so that you are starting on this from scratch.

    Then make sure that you follow my above post exactly. Any small deviation can cause a problem. It can get quite frustrating.

    I will send my findings to you later unless I hear from you that you have it working.

    Good luck,
    Subcan
  13. wmoore029

    wmoore029 Newcomer, in training Topic Starter

    think I figured it out, talked to a friend and he says I need a cross over cable, remember reading that somewhere, he is gonna make me one.. but he said it should go from lan to wan... i know it can work that way.. my question is when its all said and done will all the devices that are on the 2nd router still be able to share?

    Thanks
  14. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    Virtually all consumer networking routers support auto-crossover, eliminating the need for cross over cables.

    He's wrong, unless you want two entirely separate networks... and that's going to be quite a bit more confusing/complex for a number of reasons.
  15. subcan

    subcan Newcomer, in training Posts: 70

    wmoore029,
    As Rick said, you should not need a cross-over cable. I do use cross-over cables from my server to my switch, and from my switch to my modified wireless routers (more like wireless switches) but that is not really critical. either way it won't cause any problem because linksys does support auto-crossover.
    But... going from lan to wan will not work... that essentially keeps the router a router and does not create the "wireless switch" you need for the 2nd router. (yah it is a little confusing)
    I did take two of my routers to create a similar environment to yours... but murphy had his way and one of my power adapters is broken and I will have to wait until tomorrow remedy this.
    I did see one thing that may be an issue...
    I had to set the first router to "static IP address" for the Internet Connection settings. This might be worth trying. You would need to know your internet connections Gateway IP address (ex. 11.254.17.117). then as a "static IP" assign the 1st router an IP in same group (ex. 11.254.17.118). then you need to know the correct "subnet mask" and DNS settings.
    then in network settings assign the IP 192.168.1.1 (like you did)
    Then set up the 2nd router just like I showed you in my first example.

    I think that there may be a conflict with the modem giving DHCP to the 1st router... it might also be giving it to the second one too or just something jacked up from the whole IP protocol dealeo. Assigning a static IP to the 1st router would likely solve this problem... if it is there... like I said I will give it a try later when I have another power adapter.

    These are just some suggestion that might help... rather than waiting for me to build a test scenario.

    I hope that I am not wasting your time... just my thoughts

    Subcan
  16. subcan

    subcan Newcomer, in training Posts: 70

    Sorry i double posted by mistake... again.
  17. wmoore029

    wmoore029 Newcomer, in training Topic Starter

    thanks for the help guys..

    ok so I understand right, the (main router) i need to do static op, or the secondary router?
    I am lost. Just got home from work so thats prolly part of the reason lol
  18. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    Just a review on how I'd configure it -- Hopefully you find it useful.

    [o] <== Teh Internetz
    ||
    || <== Phone line or coax cable
    ||
    ==> Modem
    [LAN]
    ||
    ||
    || <== Network cable
    ||
    ||
    [WAN]
    ==> Main router: Cisco/Linksys WR110
    [LAN]
    ||
    ||
    || <== Network cable
    ||
    ||
    [LAN]
    ==> Second router: Linksys WRT54G
    [LAN] [LAN] [LAN] [LAN]
    \\ || || //
    || || || ||
    || || || || <== Network cables
    || || || ||
    || || || ||
    [Insert your network devices here]


    • Cisco/Linksys WR110
    • LAN IP address: 192.168.1.1 [Static/Manual]
    • Subnet: 255.255.255.0
    • DHCP: Enabled
    • Wireless: Enabled and configured
    • Wireless: Enabled and configured

    Linksys WRT54G
    • LAN IP address: 192.168.1.2 [Static/Manual]
    • Subnet: 255.255.255.0
    • DHCP: Disabled
    • DHCP Starting IP Address: 192.168.1.100
    • Wireless: Disabled

    Other devices
    • Remove all static IP addresses
    • Enable DHCP for all devices
    • Connect each device to either router using the LAN ports only

    Network devices can be plugged into any LAN port on either router. Automatic DHCP IP addresses are handed down from the WR110 and will pass through the WRT54G just like it would be with a switch. If you use the WAN port on the WRT54G, then it still routing, even if it isn't handing out IP address.. So do not use the WAN port on the WRT54G. Only use the LAN ports.

    If you're first post was correct, you've already done this stuff. You may want to just reset the routers using a hard reset and start over again. :) To do a hard reset, hold the tiny little "Reset" button in the back for several seconds.
     
  19. wmoore029

    wmoore029 Newcomer, in training Topic Starter

    ok I tried it and still same result. Have no idea what I am doing wrong.

    This is my current setup

    see below..

    Also its going from LAN 1 to LAN 1.
    2nd Router has Block Anon Req Disabled, etc (2nd router is wrtg54 v5)
    DHCP is disabled

    No ip is being leased when attached to 2nd router.
    I have hard reset both routers.
    Router 2 works independently just not as a switch.


    Thanks

    Attached Files:

  20. jobeard

    jobeard TS Ambassador Posts: 13,282   +280

    with the wrtg setting to dhcp disable AND its wan port left empty, that box ought
    to function as a switch and not a router.

    only thing that might be changed imo is to ensure it has a different router address than the wrt110 eg 192.168.2.1 to get it off the actual network of the wrt110 == 192.168.1.1
  21. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    That shouldn't be an issue, but at this point, I think it is worth trying. :haha:

    I'd recommend giving your routers a hard reset too. It resets all of the configuration data back to factory defaults. Something is not working like it *should* here. Hmm, and you mentioned you updated the firmware, which is good.

    Also, if you haven't been, it might be a good idea to restart your routers and the computer you are using to this with each time you make a configuration change. This will ensure the changes you make are propagated, which could have you chasing ghosts otherwise.
  22. wmoore029

    wmoore029 Newcomer, in training Topic Starter

    that seemed to to the trick, changing it from 192.168.1.2
    to 192.168.2.1.

    now I cannot access that routers config page... no biggie but would love to be able to.

    Also only 1 computer can access the net thru the 2nd router. My laptop connected via ethernet cannot. Computer is set to auto ip. I have reset the laptop and still nothing will try another cable and report back.

    Scratch that its 192.168.1.2 and works.. may have found the issue!!! My friggin laptop.. not wanting to work via ethernet... if this is it I am gonna scream!
  23. wmoore029

    wmoore029 Newcomer, in training Topic Starter

    ok did some testing.. laptop nic must be bad, tried new cable.. not it.. hooked to main router not it. tried rebuilding tcp/ip stack not it.. gonna uninstall drivers and redo
  24. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    Interesting, so you were using your laptop to test and the network port isn't picking up an IP address even from your primary router? :)

    When you rebuilt the TCP/IP stack, you use netsh to reset the winsock? Or did you take another approach?

    You may want to bypass the router all together to rule out any sort of router weirdness and just plug the laptop directly into your modem. Restart your modem afterward and give it 20-30 seconds. Any luck getting online?

    If you can't find the issue, I think I mentioned it's possible that your firewall software has blocked all network connectivity. You wouldn't be able to get an IP address if it is blocking ICMP data and it may be set to do so for that specific network adapter. Make sure you disable your firewall or just completely even uninstall it (I have seen firewalls cause issues like this even disabled, but uninstalling the software fixed it).
  25. wmoore029

    wmoore029 Newcomer, in training Topic Starter

    hi at work right now.. but I hooked laptop to modem and still nothing.

    I disbabled my firewall and Windows Firewall, restarted laptop

    I could not remember how to do a complete rebuild

    I just unceched Tcp/ip and applied and rechecked and applied/ reboot
    Also removed driver and did a reinstall of same driver.

    I di dnot have a place to hit remove in the tcp/ip area.

    i used to do tech support for Cox. years ago but for the life of me could not remember what I learned lol and one time had knew alot but did not retain it all since I am doing other stuff now lol
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.