2x Hard Drive failure

By bj00uk
May 15, 2009
Topic Status:
Not open for further replies.
  1. Hi, everybody

    I got two porblems

    1st - I have a 500gb GB Sata Hard Drive this was inside a Lacie External Drive I purchased, I took it on a buiness trip with me and my once I got back home I plugged it in and it just made a clicking noise. I serched around the internet and tried the freezing trick no luck.

    2nd- I have a 80gb IDE drive it had alot of information on it and it went corrupt, I formatted it and tried to use it but I still encountered problems it would not work, I transferred data over to it and tried loading them it would either dissappear of the drive or would not open and become corrupt.

    Thanks.
  2. Matthew

    Matthew TechSpot Staff Posts: 6,043   +84 Staff Member

    Sounds like both are dead - first one definitely more so than the second. Test your 80GB drive with one of the utilities here.

    If both are dead, the solution is simple: buy a new drive.
  3. FoReWoRd

    FoReWoRd Newcomer, in training Posts: 238

    try a disk check to verify they format correctly
  4. bj00uk

    bj00uk TechSpot Enthusiast Topic Starter Posts: 146

    Hi, It seems both are dead, Thanks for the help.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.