5.1 audio in game

By BMfan
Sep 22, 2009
  1. Sorry if this has been asked before.

    I have the Asus crosshair III motherboard that came with the creative xf-i mb edition sound card,what i am wondering is why my games wont play 5,1 sound,i know 5,1 and DTS works because i heard the channels when playing movies but just in the games it doesn't seem to work.
    Does anyone know if i am supposed to set something up or should it just work when i set it to 5,1 in the game menu?
    I use the optical output to my amp,the amp doesn't have the 6 analog inputs.
  2. Punkid

    Punkid TS Guru Posts: 420

    make sure you have the latest drivers and the config in the game is set to surround...many games use stereo by default
  3. BMfan

    BMfan Topic Starter

    It's the latest drivers possible from the asus website and when i set 5,1 in the game it still only outputs 2 channel.
  4. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    You only get stereo sound through digital output because 5.1 sounds in games aren't encoded in DTS or Dolby Digital. You'll need an encoder to convert the sounds to AC3/DTS on the fly. I think there's Dolby Digital Live plugin available on Creative's site - it might even be included in X-Fi software (at least it is with Auzentech's X-Fi cards).
  5. BMfan

    BMfan Topic Starter

    Would that be this Creative ALchemy software?
    Is there any way windows 7 can have 5,1 as default sound?
  6. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    No, that's for making old EAX games work in Vista/7.

    I don't know about that soundcard, but it's possible with mine (which has Dolby Digital Live).
  7. nismo91

    nismo91 TS Evangelist Posts: 899   +15

    may i know what games are you playing? some games have 5.1 in default and no option to turn it off, (i.e. rise of argonauts, nfs shift) while other older games only have stereo and does not have 5.1 capability.

    anyway, at sound, control panel in windows 7, u can click configure (if available) or set the format to 5.1 or dolby digital live. maybe it helps.
  8. tweakboy

    tweakboy TS Guru Posts: 467

    Like gurus said in config panel you must choose 5.1 sound,, then it will take effect,, gl
  9. BMfan

    BMfan Topic Starter

    The games i am playing at the moment are Call of duty 4 and world at war,
    thanx for the info guy's when i get back to my pc on either tuesday or wednesday i will try in the control panel.
    Let you guy's know if i come right.
    With cod4 i change the sound settings to 5,1 ,but it still only outputs 2,1
    and on cod5 it says i must change my default settings in windows.
  10. BMfan

    BMfan Topic Starter

    Do you think i haven't LOOKED?
    Don't post just for the sake of posting
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...