500GB Kaser Storage Vault slow transfer speed

By BrentO
Nov 20, 2008
Topic Status:
Not open for further replies.
  1. I have a 500gb kaser storage vault and its usb2 compatable but i only get usb1 transfer speeds. I have sp3 installed, I've updated drivers for the drive, i installed a new usb2 driver, i made sure the usb2 setting in the bios was on, i've uninstalled all my usb devices and restarted my computer with them plugged in, i have an inhanced usb controller but whatever port i plug into it says high speed device plugged into a nonhigh speed port. Im stuck and have nowhere else to turn. any help would be greatly appreciated.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Obviously you are plugging it into a USB 2 port on your computer?
    Some older computers only had USB2 at the back, and USB1.1 at the front

    Actually do this:

    Please put your System Specs information in your Profile

    If you have a brand name computer (like Dell; HP; or other) please place the Computer name & Model number in your Mobo field of your Profile
  3. BrentO

    BrentO Newcomer, in training Topic Starter

    i dont know what brand it is (i think its custom) but i have a asrock 775vm8 motherboard intel pentium 4 2.66gh processor 1.25gb of ram
  4. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

  5. BrentO

    BrentO Newcomer, in training Topic Starter

    sorry i ment i do have sp3 and i have updated some drivers recently, but if you think there are specific ones i should update please tell me.

    no matter what port i plug into it says high speed device plugged into a nonhigh speed port. and on the website for my motherboard it says i should have 6 ready to use usb2 ports. so im pretty lost.
  6. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Oh yeah I mean 6 USB2 ports

    Actually try this:

    Remove the 256Meg Ram card (only keeping the 1Gig in there (even if they are 512Meg cards x 2 or not)

    Then Reset you Bios Settings
    You should see a message like press "DEL" (or some other key) when first turning on your computer
    Press that key to get into Bios Setup
    Locate setup defaults (may be termed slightly differently)
    Apply it
    Then save and exit

    Check in Windows again for USB2 functionality
  7. BrentO

    BrentO Newcomer, in training Topic Starter

    I removed the 256 ram card keeping only the 1gb card in, I reset the bios to its default and saved it, but it still didn't make a difference with the transfer speed. Do you think the device might be faulty? and just so you know the drive is formatted and theres nothing on it.
  8. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    There have been incompatible USB parts before

    But please confirm the drivers, and SP3 as well (details previous post, above)
  9. BrentO

    BrentO Newcomer, in training Topic Starter

    do you think i can just take the ide drive out of the case and use it as an internal drive?
  10. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Hey, that's a good idea

    But those external drives are now laptop drives (ie the size) They use to be the same size as internal Harddries (just gone blank on the inches !)

    Anyway, you could test that
    It's probably Sata not IDE actually
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.