About hidden folders

By Kserijaro
Jul 21, 2008
  1. Anyway.The problem isn't big,but kinda annoying.Last few months I have been killing renegade viruses on my PC,with great accuracy thanks to the TS forums..Now,only one tiny thing remained i did not notice at the 1st hand.And i confirmed it today.I made a "test" named folder with no files in it.I right-clicked the folder and the options show.I went in properties.I deselect Read-only and select hidden.Then I pressed Apply and ok to close the options.Desired effect was shown:Folder was indeed hidden.And now the deal...I went to folder options to enable the View hidden folders .I click apply and ok ,and nothing..."test" is still hidden and doing ctrl+a tells me there is one hidden folder and i should enable View hidden folders to see it.I have never seen this message,and it is strange that folder options don't react to commands.Basically ,
    Folder options revert to own set of rules after i click ok.Is there easy way to fix this?
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    "Is there easy way to fix this?"...

    Yes, format the hard drive and reinstall Windows fresh ;)
  3. Boogityboo04

    Boogityboo04 TS Rookie Posts: 302

    I have this sort of problem, but the folder is so well hidden that "Show hidden files and folders" doesn't reveal it. The only way to access it is to type the path into the address bar. If someone could help fix this it would be really helpful.
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Follow all the steps precisely

    1. Click Start -> Run
    2. Type regedit and click Ok.
    3. Find the key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ Advanced\Folder\Hidden\SHOWALL
    4. Look at the “CheckedValue” key… This should be a DWORD key. If it isn’t, delete the key.
    5. Create a new key called “CheckedValue” as a DWORD (hexadecimal) with a value of 1.
    6. The “Show hidden files & folders” check box should now work normally
    7. Also change in NOHIDDEN change value to 1
    8. In SHOWALL change value to 0
    9. Re-check the folder options
    10. now change the values to the same
    NOHIDDEN to 2
    SHOWALL to 1

    Strange, but has worked before.
  5. Kserijaro

    Kserijaro TS Rookie Topic Starter Posts: 57

    Thank you,setting the CheckedValue to 1 fixed my problem completely.So,creation of new value wasn't necessary ,for it had DWORD as posted.Thank you again!
  6. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    Thanks for me also kimsland! I have saved this for a time when needed.
  7. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Thank-you for the replies

    Many support members are not aware of this reset trick. That does seem to work most of the time. In all cases I have seen this issue, I have done the above as the first option to solving it, in 9 out of 10 cases it works :)
  8. Boogityboo04

    Boogityboo04 TS Rookie Posts: 302

    Eh, didn't seem to work for me. This problem doesn't seem to be registry related for me, it seems to be an actual file system setting that I cant change, because they are hidden in both Vista and XP.
  9. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    So what kind of files did you hide in the first place?
  10. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    System file attribute by chance?
  11. Boogityboo04

    Boogityboo04 TS Rookie Posts: 302

    I'm not sure, it's my entire user folder that has hidden itself. (not pron tmagic :p) How would I un-system file attribute it?
  12. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Open Control Panel
    Then Folder Options
    View tab
    Un-check "Hide protective operating system files"
    Ok (or yes prompt)

    Refresh your folder again (just re-open it, to view your files)

    Now can you see them?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...