TechSpot

About  npctrl.dll

By learninmypc
Apr 2, 2012
Post New Reply
  1. On the extremely rare chance I use IE8, a couple days ago I clicked the IE icon & instead of it going to my homepage,it went to msn.com & there was a browser wide notice telling me I need to install npctrl.dll IF I trust Microsoft.
    I googled it & amongst the results I saw this http://www.processlibrary.com/directory/files/npctrl/403908/
    My Microsoft Silverlight is up to date so I simly want to know if I truly need to install it or not?
    Plus, ALL my scans come up clean. TIA
     
  2. learninmypc

    learninmypc TS Evangelist Topic Starter Posts: 6,531   +332

    Well, I'm guessing there is no solution?
     
  3. Rabbit01

    Rabbit01 TS Evangelist Posts: 777   +57

    Not sure why it wasn't installed when you installed Silverlight. It's not in the default folder? In my case, it's "C:\Program Files\Microsoft Silverlight\5.0.61118.0".

    Looks like FF uses this file also.
     
  4. learninmypc

    learninmypc TS Evangelist Topic Starter Posts: 6,531   +332

    I followed your path & it shows in there so I guess I'm :confused:
     
  5. Rabbit01

    Rabbit01 TS Evangelist Posts: 777   +57

    Is it enabled in Manage Add-ons under Internet Options? If not, try enabling it, if already enabled, let it install the file when prompted. I don't think it will pose any problems.
     
  6. learninmypc

    learninmypc TS Evangelist Topic Starter Posts: 6,531   +332

    Yep, it shows as enabled. I'll click the thingy & see what happens. Will post back,too.
     
  7. learninmypc

    learninmypc TS Evangelist Topic Starter Posts: 6,531   +332

    Well, it seems to be working now. I simply had to click the info bar & no download. Will post back if it changes.
     
  8. learninmypc

    learninmypc TS Evangelist Topic Starter Posts: 6,531   +332

    Ok, so I spoke too soon :(. I've run all my scans M-bam,Spybot,MSE,Eset & SAS & they all came up clean yet on the extremely rare occasion I use IE,it now goes to msn.com & not my home page which is http://www.kirotv.com/
    UNfortunatly I've deleted the scan logs:( Any ideas?
     
  9. learninmypc

    learninmypc TS Evangelist Topic Starter Posts: 6,531   +332

    Ok, I believe I fixed the problem.
    Evidently on one of the SUPERantispyware program updates,I neglected to go into the Preferences>Hijack Protection Tab & put my home page in . Prior to doing such, my IE 8 went to msn.com . I put my home page in SAS ,clicked ok & X'd out of SAS ,rebooted & upon opening IE,it went to my NORMAL home page,NOT MSN. YES:)(y)
     
  10. Rabbit01

    Rabbit01 TS Evangelist Posts: 777   +57

    Guess I've been lucky, haven't had the problem of homepage being changed.
     
  11. learninmypc

    learninmypc TS Evangelist Topic Starter Posts: 6,531   +332

    Well, only time will tell for sure. But since I did the correction, about 5 days ago, it hasn't gone back yet.
    I'm hoping it don't. I didn't want to post the correction till I knew "matter of factly", but since I mentioned it in another thread,I figured I'd do so here. So far so good.:)
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...