TechSpot

Acer Aspire 4520 won't POST after reboot

By DeltaPhoenix
May 26, 2011
Post New Reply
  1. My Acer Aspire 4520 is able to boot after being without power for about 1 minute, and it runs smooth, but it just fails to reboot. It should be related to BIOS, since if I insert the CMOS battery, it won't boot at all. I tried to enter BIOS setup after the first boot and just save everything as standard, resulting in an instant-reboot, but still no POST. I've been troubled about the laptop for a month, but still haven't found an solution.
    Another thing: It's unable to boot when then default power battery is present, even if the cable is plugged. I can only make it boot without any kind of battery present, and only the power cable plugged. I can then insert the power battery and it will still function until it is shutdown. But it still can't reboot, no matter how I it. Even if I just hold the power button until it turns off and instantly turn it on again.

    So, does anybody have an idea what I can do?
     
  2. Mark56

    Mark56 TechSpot Paladin Posts: 2,271

    Sorry, but this post is very confusing and I am not quite sure what you are saying about the CMOS battery, if it won't boot with it fitted maybe the battery is faulty, fit a new one and try again.

    If you have the same problem with the laptop battery this also may be faulty.

    You could try to explain again so your problem is a bit easier to understand.
     
  3. DeltaPhoenix

    DeltaPhoenix TS Rookie Topic Starter Posts: 44

    Explain better, okay.

    I already tried another CMOS battery already, but it still won't work whenever it is present.

    I don't believe the power battery is faulty, since I can boot the computer, insert the battery and unplug the power cable and it still runs.

    The main problem is, I can boot the computer, but I can't reboot it. When I shut it down, I have to wait 1-2 minutes before I can power it on again, else it won't POST at all. When any CMOS battery or the power battery is present when I try to boot, it won't POST either, no matter how long I wait.
     
  4. Mark56

    Mark56 TechSpot Paladin Posts: 2,271

  5. DeltaPhoenix

    DeltaPhoenix TS Rookie Topic Starter Posts: 44

    No changes were made at all. However, I was installing Windows XP at the time it started doing this, after the first reboot in the setup. I've had the same problem since then.
     
  6. Mark56

    Mark56 TechSpot Paladin Posts: 2,271

    With all the batteries in place will it boot from the windows disc? If so try to install it again.

    If the reinstall keeps failing I would suspect your hard drive is faulty or you have a problem with the memory.

    Why were you reinstalling, was there a problem?

    Answer this and we can move on.
     
  7. DeltaPhoenix

    DeltaPhoenix TS Rookie Topic Starter Posts: 44

    With ANY battery in, it won't boot at all, not even POST.
     
  8. Mark56

    Mark56 TechSpot Paladin Posts: 2,271

    Please answer my last question.

     
  9. DeltaPhoenix

    DeltaPhoenix TS Rookie Topic Starter Posts: 44

    Oh, my bad.

    It had no problems, just wanted XP instead of Vista.
     
  10. Mark56

    Mark56 TechSpot Paladin Posts: 2,271

    OK, so this problem only started when you installed XP and it was fine before you formated the hard drive. Did you download and install all the XP drivers and utilies from the Acer site?
     
  11. robin_bga

    robin_bga TS Rookie Posts: 258

    Hi,
    This problem can be caused by many things some of which are Old bios failure, water/liquids spilling in the laptop, burnt chips causing a short circuit, etc.
    The first suggestion that Mark56 gave was a good start, you should download and install new bios, if that fails then i think you have to visit a repair shop close to you.
    However i also wonder what happens if you let it start, then when it starts, you install a battery while its on?
     
     
  12. Mark56

    Mark56 TechSpot Paladin Posts: 2,271

    Thanks for the input Robin. The OP has said that nothing happened or was causing a problem until the OS was changed, I suspect it may be caused by the lack of the correct drivers for this particular laptop, may be something to do with power management.

    Your closing question is answered in post 3.
     
  13. DeltaPhoenix

    DeltaPhoenix TS Rookie Topic Starter Posts: 44

    But now it runs Vista again, with all the proper drivers. And even so, it doesn't load any drivers until after the POST anyways.

    And if I insert the CMOS battery after I boot the laptop, it just freezes at the spot.
     
  14. Mark56

    Mark56 TechSpot Paladin Posts: 2,271

    Well, I have to admit I am out of ideas, other than flashing the Bios and in the Bios settings select "Load Optimun Defaults" with the CMOS battery left in.

    My only other thought is that the power board is faulty which can only be checked by an expert, there is no way of doing this via the forum.
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.