add/remove programs doesnt work

By lamensterms
May 26, 2006
  1. whenever i try to run the add/remove programs utility i get an error message.
    im running xp and when i open the utility it tries to populater the list, then gets this message. the message is titled "Run a DLL as an App" and reads "Run a DLL as an App has encountered a problem and needs to close. Etc..."

    another problem i am having is there is no drive manager in computer management. so i cannot format or partition any drives.

    any help would be great.
  2. PCBob

    PCBob TS Rookie

    Here is a Work Around

    I have the same problem with Add/Remove Programs not working on a Toshiba laptop. I have tried numerous searches in vain looking for a solution to the "Run a DLL as an App has encountered a problem and needs to close" error.

    However, I have found a solution by going a different route. "My Uninstaller" is a FREE software product from NirSoft that has saved my sanity. The software works and provides a lot more info than "Add/Remove Programs".

    Here is a link:
  3. N3051M

    N3051M TS Evangelist Posts: 2,115

    have you tried to repair those sysem files (reinstalling them through windows repair/console/safe mode)

    it could be that your pc has been infected.. run through these to check.. follow all instructions. post ones you run into trouble on...
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...