TechSpot

Add Switch into Network

By Bloo Ice
May 2, 2005
Topic Status:
Not open for further replies.
  1. IronDuke

    IronDuke TS Rookie Posts: 1,267

    That is APIPA. I meant setting DCHP on the router. Probably not a lot of difference though.
  2. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 123

    Sorry, I didn't clarify myself. But yes, DHCP is [and was] enabled
  3. mickylaren

    mickylaren TS Rookie Posts: 17

    Are both your switch and router Linksys models? If so, ensure that both are not set to have an ip address of 192.168.1.1. Change the switch to 192.168.1.2
  4. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 123

    How do I change the switch?
  5. IronDuke

    IronDuke TS Rookie Posts: 1,267

    If you've enable DHCP why are you using 169.254.x.x. Your router is probably set to 192.168.1.1
  6. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 123

    It was set to use the IP DHCP gives it. I'll re-try it with manual IP.
  7. IronDuke

    IronDuke TS Rookie Posts: 1,267

    169.254.x.x is the address range Windows uses when it doesn't find a DHCP,
  8. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 123

    Ok, I just pinged with the manual IP, and pinged my router. It got 1 reply, and the IP of 2 other computers [the only 2 that are turned on right now].


    C:\Documents and Settings\Brian>ping 219.206.244.100

    Pinging 219.206.244.100 with 32 bytes of data:

    Reply from 219.206.244.100: bytes=32 time<1ms TTL=150
    Request timed out.
    Request timed out.
    Request timed out.

    Ping statistics for 219.206.244.100:
    Packets: Sent = 4, Received = 1, Lost = 3 (75% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

    C:\Documents and Settings\Brian>arp -a

    Interface: 219.206.244.102 --- 0x2
    Internet Address Physical Address Type
    219.206.244.100 00-06-25-e6-47-07 dynamic
    219.206.244.101 00-07-95-af-b0-a6 dynamic
    219.206.244.200 00-e0-18-25-52-56 dynamic
  9. IronDuke

    IronDuke TS Rookie Posts: 1,267

    This address belongs to SOFTBANK BB CORP. (219.206.244.100)

    Your router should be on 192.168.1.1. Enter this in your browser and check that DHCP is actually enabled. Here you'll set the range for the addresses it hands out the default is 50 starting at 192.168.1.100 I believe.
  10. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 123

    Well, because I have wi-fi, I changed it to 219.206.244.100 instead of the 192.168.1.1...just an extra security meausre I guess. Yes, DHCP is enabled, as you could see that one computer was using DHCP [the 219.206.244.101].
  11. IronDuke

    IronDuke TS Rookie Posts: 1,267

    Seems like it is too secure.
    I sugest you use one of the private address

    IP Address:
    10.0.0.0 - 10.255.255.255
    172.16.0.0 - 172.31.255.255
    192.168.0.0 - 192.168.255.255
     
  12. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 123

    So use 172.16.0.0 for the router IP and 172.31.255.255 for the router subnet?
  13. IronDuke

    IronDuke TS Rookie Posts: 1,267

    No. All subnets must be the same 255.255.255.0 will do fine.
  14. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 123

    Ok. I set the router as 192.168.1.1 with the subnet as 255.255.255.0
    I manually set this computer as 192.168.1.102 subnet 255.255.255.0 default gateway 192.168.1.1 and DNS servers correctly.

    C:\Documents and Settings\Brian>ping 192.168.1.1

    Pinging 192.168.1.1 with 32 bytes of data:

    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.

    Ping statistics for 192.168.1.1:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

    C:\Documents and Settings\Brian>arp -a

    Interface: 192.168.1.102 --- 0x2
    Internet Address Physical Address Type
    192.168.1.1 00-06-25-e6-47-07 dynamic
    219.206.244.200 00-e0-18-25-52-56 dynamic
  15. IronDuke

    IronDuke TS Rookie Posts: 1,267

    Set the address as automatic and then restart Windows. In the Run box type cmd /k ipconfig to check what the address has been given to your machine.
  16. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 123

    Should I have the cable coming IN from the router plugged into the Uplink or just a regular port on the switch? I've been trying it with both, but if I knew which one to use it'd make things a whole lot easier and quicker.

    Windows IP Configuration


    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . :
    Autoconfiguration IP Address. . . : 169.254.217.130
    Subnet Mask . . . . . . . . . . . : 255.255.0.0
    Default Gateway . . . . . . . . . :

    Ethernet adapter Bluetooth Network Connection:

    Media State . . . . . . . . . . . : Media disconnected

    No go. Still didn't work.
  17. IronDuke

    IronDuke TS Rookie Posts: 1,267

    Cable should go into the Wan port which is probably separate.
  18. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 123

    On the switch I dont have that. I only have Port 1 2 3 4 5 and Uplink
  19. IronDuke

    IronDuke TS Rookie Posts: 1,267

    Can we check the stae of play? Leave the switch out of it for the moment, although the computers are connected into 1-5. It only has 5 ports so if the uplink port is connected port 5 is disconnected.

    Do we have:
    Modem connected to Wan port on router.
    1 computer wired to router.
    Router set to 192.168.1.1
    Subnet 255.255.255.0
    In the Run box type cmd /k ipconfig to check what the address has been given to your machine. What does this say?
  20. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 123

    From a computer wired to the rotuer

    Windows IP Configuration


    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . : sctelcom.net
    IP Address. . . . . . . . . . . . : 192.168.1.100
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.1

    Ethernet adapter Bluetooth Network Connection:

    Media State . . . . . . . . . . . : Media disconnected

    Those computers plugged directly into the router run just fine. Once it goes through the switch is where the problem crops up.
  21. IronDuke

    IronDuke TS Rookie Posts: 1,267

    Right this looks OK. Plug a patch lead into the router and connect it to the switch any port 1-5. Connect another computer to the switch. Check to make sure it is set to obtain an address automatically. On this computer check its address with cmd /k ipconfig /all.
  22. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 123

    I'm sorry, but what do you mean?
  23. IronDuke

    IronDuke TS Rookie Posts: 1,267

    Connect the router to the switch with an ethernet cable.
  24. tdeg

    tdeg TS Rookie Posts: 348

    I have a very similar setup that works like a charm.

    Hello.

    I use a very similar setup at work and home. Piece of cake to set up.

    First, reset your router by holding the reset switch. If you use DSL for highspeed (think you said you did), make sure you have the logon for it (if your DSL requires it).

    Next, set everything up like the diagram I attached.

    The Linksys router will have the DHCP server enabled by default. This will give out IPs in the range of 192.168.1.100 -> 192.168.1.150. This is fine, you can leave these on. Don't worry about trying to be more secure by using other IPs, you'll just have more problems.

    The Linksys router will have an IP address of 192.168.1.1 . This is ok. The default password will be admin. You will want to change this as soon as you log in.

    If you hook everything up like in the diagram and have your computers set to automatically obtain an IP, then they should be talking. You should give them both a reboot though just to make sure they grab a new IP.

    The first computer to obtain an IP address will be given 192.168.1.100. The second will be 192.168.1.101. Go to a computer and go Start->Run->cmd . At the command prompt, type " ipconfig ". If the ip ends in 100, try to ping 192.168.1.101. If the ip ends in 101 , try to ping 192.168.1.100.

    The reason I put the XBox at 192.168.1.151 is because that is outside the IP pool of the LinkSys DHCP server. I have a playstation and give it that address because I then enable the DMZ in the router and point it at that. Makes life easier.

    Anyways, this is just the basics... I'm tired and its late.. Tommorrow I will get into securing your wireless and setting up port forwarding and such so that you can use things like BitTorrent at full tilt.

    Cheers,

    TdeG

    Attached Files:

  25. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 123

    See, the problem is that there is no uplink port on the router
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.