TechSpot

Adding graphics card, blank screen

By jespo1351
Nov 23, 2011
Post New Reply
  1. HI,

    I want to upgrade my graphics and I am pretty sure the card I bought is compatible. I get a blank screen when starting with the card in and it plugged into the monitor. I have a drivers disc but can't use it because I can't see anything.

    Windows 7 32 Bit OS

    Here are the specs

    I have Biostar Mobo N68S3+ with an AMD X2 Phenom processor ang 4Gb of RAM
    My PSU is 220-240 400W
    The card is a Galaxy GT 440 1026mb

    I currently use the integrated graphics to connect to the monitor

    Do they just not match or am I doing something wrong?

    Much appreciated
     
  2. megamozg

    megamozg TS Rookie

    Have you checked if your inserting the card properly? Can you access BIOS at least? When do you see the white screen?
     
  3. fimbles

    fimbles TS Evangelist Posts: 1,160   +198

    Are you plugging your monitor in to the graphics card or the intergrated graphics port?

    Stupid question i know, its the "I currently use the integrated graphics to connect to the monitor" sentence in your OP that confused me :p
     
  4. jespo1351

    jespo1351 TS Rookie Topic Starter

    I am plugging it into the graphics card and it is inserted correctly...

    Is there a setting in the BIOS I should change?
     
  5. megamozg

    megamozg TS Rookie

  6. jespo1351

    jespo1351 TS Rookie Topic Starter

    Ok that may be what I have missed.

    I will try and report back when I get home.

    Thanks!
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...