TechSpot

Adobe Bridge CS4 fails to start

By JesseM
Jun 1, 2010
Topic Status:
Not open for further replies.
  1. I've been running Bridge/Photoshop CS4 fine for many months, but all of the sudden Bridge won't start. I get the error "Bridge has stopped working" from Windows before anything pops up. I have done lots of research into this issue and a popular solution is to Ctrl+Click the Bridge shortcut and reset all the settings and purge the cache, but after I click "OK" it just crashes again. I have also tried uninstalling and reinstalling Photoshop & Bridge. Photoshop opens and runs fine.

    The only possible cause for this I can think of is a couple days ago I accidentally shorted out a USB port by putting a stereo plug in it (the headphone jack and USB port were very close together) which instantly turned off my computer and ran some kind of hardware diagnostic/recovery utility during bootup. When the computer was done booting there were a few things that just didn't seem quite 'right' although nothing was noticeably wrong (my web browser settings were reset, and desktop icons were rearranged, etc.). The computer's been running just fine since then, with the exception of this Adobe Bridge issue.

    Any ideas? Thanks!
  2. JesseM

    JesseM TS Enthusiast Topic Starter Posts: 259

    Apologies for bumping, but the problem is persisting after two weeks. I'd appreciate any ideas!
  3. JesseM

    JesseM TS Enthusiast Topic Starter Posts: 259

    Problem solved! Turns out my IZ3D driver was running in the background and was keeping Bridge from starting. Hope this info can help others who are having the same problem.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.