Albatron motherboards

By foxyrinoa
Apr 4, 2008
  1. ok, so hear is the problem i am having. I recently purchaced a new motherboard about four months ago to replace my very ancien amd. unfourntaly before i had the computer compleatly up and running, we moved. since the move i have lost the motherboard disk with all of the drivers. i have most of them and installed them. the only thing not working is my onboard sound. i have a albatron px848 motherboard. even though i installed the sound drivers, when i go into the controll panel and try to set up my speakers, it says that there is no device and i have no sound when i play anyting. i was wondering if there was someone who could point me in the right direction for a driver as i have been looking online all night and cannot seem to manage to find the right motherboard drivers. all i have found is bios drivers. i need to have my sound up and running asap as i cannot live without my music. any help would be aprecated!
    thank you.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Umm which one?


    Actually their home page was down anyway (Info here:
    I found this information here:

    And what Windows version are you using anyway?

    You might want to keep trying their homesite, until it comes back online
    Seems a beauty of a support page!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...