Anyone else getting an error when installing Vista SP1?

By ryan29121
Mar 19, 2008
Topic Status:
Not open for further replies.
  1. I just got vista SP1 today and went to install it and i get an error message half way though it. Error code: 0x8007000D. I tried looking high and low for a solution but couldn't find anything. Does anyone know how to fix this issue?
  2. raybay

    raybay TechSpot Evangelist Posts: 10,716   +6

    Do you have the legal version of the SP1?
    There are a lot of problematic beta's floating around that cause that.
  3. ryan29121

    ryan29121 TechSpot Enthusiast Topic Starter Posts: 182

    The version of SP1 is completely legal. I downloaded it from microsoft.com
  4. gamerex

    gamerex TechSpot Enthusiast Posts: 176

    Install all the prerequiste updates?
  5. LNCPapa

    LNCPapa TS Special Forces Posts: 4,273   +258

    I'm having problems getting it installed on a new laptop I just bought for my wife on Valentine's Day. It's the original install from Dell and I haven't really installed much except for Office 2007. When I ran a sfc /scannow it came back with complaints about corrupted files.

    On the other hand I installed SP1 on one of my laptops that's been running Vista Ultimate 32 bit for some time now with tons of crap installed - the install went fine though it did take nearly 1.5 hours to complete on a fairly fast T7600 MacBook Pro.

    I'll have to spend a little time troubleshooting the problem when I get some time to see if I can get my wife's patched up. I have noticed much better network performance after updating.
  6. ryan29121

    ryan29121 TechSpot Enthusiast Topic Starter Posts: 182

    Yes all prerequisite updates are installed. Every time I try to install it I get this error message. I tried both the full installer from microsoft.com and the windows update. Both display the exact same error message. Any suggestions?
  7. raybay

    raybay TechSpot Evangelist Posts: 10,716   +6

    Sounds like the standard VISTA problem of not finding the correct configuration.
    Only suggestion is to await the Disc version, which Microsoft will sell in April for $3.46 shipping in the mail.
  8. gamerex

    gamerex TechSpot Enthusiast Posts: 176

    Try running checkdisk, and redownloading the installer. SP1 installers like to be corrupt. Certain extensions do that, or extension code pakages. It's probaly an .msi or even an deadly .cab in disguise.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.