Asrock P4V88+

By worldwidecom
Feb 27, 2006
Topic Status:
Not open for further replies.
  1. I just tried to repair a system. I suppose the motherboard was broken.
    I bought another Asrock P4v88+. I just install all the devices back.
    I power on the pc but no bios screen appears. No sound from the motherboard.
    If put out the memory and hear some continue beeps.
    Can be the cpu broken? Which is the reason?
    Thanks
  2. Eric Legge

    Eric Legge Newcomer, in training Posts: 224

    If you pull out the memory modules you will hear BIOS beeps because the system can't function without the memory modules installed.

    If the memory is bad, incompatible, or not installed properly in the DIMM sockets, the power supply will work, but only the processor's fan will spin.

    I hope that you didn't remove the memory while the PC was switched on.

    The PC must be switched off at the mains when you remove or add components. Only serial USB, FireWire, and SATA hard drives can be plugged in or removed while the PC is on.
  3. worldwidecom

    worldwidecom Newcomer, in training Topic Starter

    Solved

    Thank you for your fast answer.
    I just clear the cmos.
    Now the system work
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.