Asus A8N SLI Deluxe Worst Motherboard ever?

By Kris55
Mar 21, 2009
Topic Status:
Not open for further replies.
  1. Hey all,

    My first post! and I am sure one which will get loads of flame replies (yay!)

    I have had an Asus A8N SLI Deluxe since 2005, and I am sure I am not the only poor person in the world to have SO many problems with it?

    here is a handful of things it does:

    1) Forgets where SATA hard drives are
    2) Cant find resources to make graphics card work
    3) Cant find 512mb of memory at random times
    4) Cant find my soundcard even though it is up-to-date and working
    5) BSOD at random times
    6) At random times terrible loud busts of white noise scream out from speakers and today my headphones, they almost had a legal case of me going deaf!
    7) Every single shutdown of system creates errors on the hard drive needing chkdsk every boot up
    8) Computer goes extremely unstable when using SLI Mode, to the point it won’t even boot up
    9) System burps and dies when over clocking at 2%
    10) System 'forgets' where the keyboard is which stops me using BIOS
    11) Northbridge fan breaks which can be the root of the problem
    12) 'Forgets' where my network ports are
    13) Switching power off to the system resets CMOS (battery works)
    14) Graphics boots in 4-Bit Mode

    I can hear the laughter from those of you who are saying "fresh install of XP" or "Change your sound card" and I can hear the clever ones who are saying "Threw the damn thing out the window all ready!"

    As my saying goes "The only way to make a computer go faster is to throw it out the window"

    I have been in the PC building business for a good 15 years now, and know my way round almost any problem.

    But this Asus A8N SLI Deluxe has to have been the root of 99% of all crazy and illogical problems I have ever seen.

    Today my Asus A8N SLI Deluxe may have just died. This morning I wanted to play a nice game and relax. Suddenly loud white noise blasts my ears to bits (wearing headphones) PC locks up.

    Last night it BSOD on me and forgot where my hard drives were, it took an hour of switching on and off, BIOS checks and CMOS resets to get it to 'see' them again.

    Anyway, back to this morning. I was shocked and my ears were ringing, so I have to hard reset my PC.

    First go and windows freezing on XP loading screen. Ok I think switching you off and fixing you later (Up until an overhaul a few weeks back used to take 30 Minutes to boot up)

    Come back to it a few hours later, ready for its normal problems so I can fix them as I always do. However today is different.

    Booted it up, and worked (Phew!) but then *pop* it boots to windows in 4-Bit mode. Damn it!

    So I fix it, after about 10 minutes (So used to that problem now), loaded my game and 'WTF?' where is my sound? Close the game to find 'Audio Device not found'

    And that as they say is history I have spent the last 4 hours of my life trying to fix this terriable motherboard. I go to the ASUS web site to update BIOS (using the same BIOS as installed at the factory) and their download site is down (Pulls hair out)

    Then I come on here to see people saying don’t update the BIOS!
    ZOMG!

    I do think this mobo is dead for sure this time, but just to check to see if my thoughts are right... could this all be down to the Northbridge overheating and dying?

    If anyone is thinking of getting a Asus A8N SLI Deluxe please for the love of all that is computer-ish in this world dont!

    Anyways your thoughts please people! I have told my PC geek friends about these problems and they point and laugh some look confused as hell when they see it for themselves.

    Hardware:

    AMD 64 x2 4800+
    1.5Gb Memory (so it doesnt crash)
    150GB 10,000RPM HDD
    2x 74GB 10,000RPM HDD
    700W SLI PSU
    Creative Sound Card
    1x 7900GTX (Used to be in SLI but dies with two cards in)
    Liquid Cooled
  2. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

  3. Kris55

    Kris55 Newcomer, in training Topic Starter

    Typical isnt it :blackeye:

    Wish I had the cash to update! The world situation doesnt help :p
  4. klepto12

    klepto12 TechSpot Paladin Posts: 1,364   +9

    i had the same board and i had tons of problems ended up driving me crazy i replaced it with a an evga board. problems went away
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.