TechSpot

Asus Eee PC 900

By JennyeeePC
Mar 18, 2013
Post New Reply
  1. Hi,
    I purchased new ram (Kingston ValueRAM 2GB 667MHz DDR2 Non-ECC CL5 SODIMM Notebook Memory.) I accidentally installed it with the power cable still plugged in, not sure if anything was damaged. BIOS recognizes the new ram but won't POST. Any suggestions?
    [​IMG]
  2. Zoltan Head

    Zoltan Head TS Enthusiast Posts: 268   +27

    Try removing the new RAM again, see if the device will POST? If it will, perhaps the RAM's faulty or needs reseating, if not sounds like the Eee's damaged. Hope this helps :)

    PS With the power off!!
  3. JennyeeePC

    JennyeeePC TS Rookie Topic Starter

    I have tried reseating both the old ram and new ram, bios recognizes the ram but again it won't post. I have tried booting from a USB but I keep getting a disc error
    [​IMG]
    [​IMG]

    [​IMG]

    What could have been damaged? what a silly mistake..
  4. JennyeeePC

    JennyeeePC TS Rookie Topic Starter

    Thank you in advance
  5. JennyeeePC

    JennyeeePC TS Rookie Topic Starter

    I swapped out the hard drive for the old one.. it's working now.. well now I know what I damaged :(


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.