TechSpot

Asus en7600gt updated drivers,now no display!

By cris
Mar 10, 2007
  1. Hi guys,

    I have got a bit of a problem and im not shure how to sort it out.
    I have a Asus en7600gt.
    I have had the original drivers installed scince I built the pc and its been running sweet,I decided to update the drivers now I have no screen after the board boots.
    I turn the pc on,the screen comes up with the board award detail then it goes to boot of the HD and the screen goes black,there is power to it but its just a black screen.
    I can got into the bios and change the boot settings, I changed it to boot of the DVD-ROM so i could do a restore of the xp disc and the screen is still black.

    I Don't now where to go from here.

    Im running windows XP x64

    It would be great if someone could help.
     
  2. Rayss523

    Rayss523 TS Enthusiast Posts: 102

    You really dont need to run the restore disk. You just need to get windows to start up in safe mode.
     
  3. cris

    cris TS Rookie Topic Starter Posts: 35


    Yeah I tried that still nothing! the screen is still black,it's like the HD is dead,or has no power but saying that it should boot of the of the cd.
     
  4. cris

    cris TS Rookie Topic Starter Posts: 35

    I think it's a dodgy harddrive,I tried all day yesterday to sort out the problem with no luck so I gave up.
    I turned the pc on this morning and it booted up as normal,as if nothing is wrong.bloody pc gremlins.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...