ATI drives on SUSE 10.1

By comp_noob14
Jan 4, 2007
Topic Status:
Not open for further replies.
  1. i recently just did a dual boot with windows xp and SUSE 10.1 but it wont go out of 680x420 resolution so naturally i think to download video drivers. so i go to the ati website and download the drivers for linux and go to installl them but get an error stating that gedit couldnt open it. something about it being a binary file or something like that. what im i doing wrong or where is another place to download the driver for my ati gfx card
  2. Jesse_hz

    Jesse_hz TechSpot Maniac Posts: 638

    Instead of clicking on the driver package, try typing the following in a console/terminal:

    sudo sh <name of driver>.run

    Edit: You need to cd to the directory where the driver package is. If it's on your desktop, try typing "cd ~/Desktop" before typing the above. Hope it helps.
  3. comp_noob14

    comp_noob14 Newcomer, in training Topic Starter Posts: 26

    i got it to run but still having trouble switching my resolution and stuff. not sure if theres some commands i need to type into the terminal after its installed to get it to actually install the the drivers. also it asks for a installation path i just entered in where i saved the driver to. not sure if that is correct or not?
  4. Jesse_hz

    Jesse_hz TechSpot Maniac Posts: 638

    I'm not familiar with ATI's drivers, but if the installer suggested a default directory, then go with that one.
    After the drivers are installed, you probably need to either restart your X-server (Ctrl-Alt-Backspace) or restart your computer.
  5. comp_noob14

    comp_noob14 Newcomer, in training Topic Starter Posts: 26

    well i found out where ot change my resolution and it only has one option 620x480 or whatever. tried to go through all the commands for the ati drivers but didnt seem to help. this is really frustrating lol
  6. Jesse_hz

    Jesse_hz TechSpot Maniac Posts: 638

    There is a pretty good guide here on installing ATI drivers with SUSE 10.1. The guide is for an older version of the drivers, but I think most of it still applies.

    Also remember that you need to leave your graphical environment before installing the drivers by typing "init 3" in the console.
  7. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,245   +213

    Why didn't you get the drivers through YaST?

    You can add resolutions by editing your /etc/X11/xorg.conf (you'll have to sudo in, something like sudo gedit /etc/X11/xorg.conf) just scroll down to where you start seeing the various resolutions being displayed, one of them shoudl be the "620x480" you are seeing (although thats odd, normally you'd see 640x480). To the left of that add the resolution you want. Save. Restart the x-server. (ctrl alt backspace after saving in gedit, then type startx at the prompt).
  8. Jesse_hz

    Jesse_hz TechSpot Maniac Posts: 638

    I don't know about SUSE since I don't use it, but not all distributions provide up-to-date drivers through their packaging system.
  9. comp_noob14

    comp_noob14 Newcomer, in training Topic Starter Posts: 26

    i didnt get them through there cuz i didnt know how (dont) first time using linux ever so not really sure how it all works yet. when i typed in the command this is what i got

    @linux-fmxd:~> sudo gedit /etc/x11/xorg.config
    root's password:

    (gedit:4090): Gtk-WARNING **: cannot open display:

    not sure what that means but if u could point me in the general direction of getting them through YaST that would be cool too lol
  10. Jesse_hz

    Jesse_hz TechSpot Maniac Posts: 638

    There a guide about doing that here.
    Sorry that I can't be of much help, but I don't know much SUSE.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.