TechSpot

ATX 12v power connector

By aju_urs
Feb 4, 2007
Topic Status:
Not open for further replies.
  1. hi guys,

    i had a problem as my computer was switched off suddenly.after all the checkings i found that 12v atx power connector on mother board is not functioning.

    case1: i tried connected both the 20pin and 12vatx pin and try switching on power nothing moves

    case2: i tries connecting only 20pin on motherboard the power comes and fan on the proccesor starts moving. but if i connect both the pins on motherboard nothing is happening

    so can anyone please tell me what is the problem and what i have to replace.
    [/LIST]
     
  2. N3051M

    N3051M TS Rookie Posts: 2,800

    you're PSU might have blown.. Replace that first.

    If its a crappy generic PSU, then it could have taken more than just itself out when your power cut.
     
  3. aju_urs

    aju_urs TS Rookie Topic Starter

    hi

    ya idid replace the power supply unit
    but still the same problem
     
  4. foozy

    foozy TS Rookie Posts: 267

    Does it speed up to full RPM? Or does it just flutter a bit and die, with power still being applied?

    If it just flutters thats a good indication of a blown motherboard or melted cpu, which is a whole 'nother mess of problems.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.