AVerTV USB2.0 Wont run

By Ross
Nov 19, 2004
  1. Hi

    I have a Dell 4600 P4 2.8 with AVerMedia AverTV USB2.0.
    AverTV USB2.0 was working at first but then it started coming up without
    sound then not coming up with the remote so i reinstalled but the samething kept on happening. So I Re-installed Windows XP Family Edition, then downloaded the SP2 and the New AverMedia Driver 2.21. Then it came up with the error saying that it couldnt find usbtvdll.dll

    I Hope someone can help cause it is driving me nuts!

  2. Ross

    Ross TS Rookie Topic Starter

    Are there maybe other drivers i could download that would work with my hardware?

  3. Sleeper

    Sleeper TS Rookie

    The same problem

    Hi, I have the same prob.
    I also have Sp2

  4. Ross

    Ross TS Rookie Topic Starter

    Sorry mine still isnt working, no one seems to know what is wrong!my next step is to format my hard drive and start again!.

  5. Sleeper

    Sleeper TS Rookie

    Hi Ross,
    Did you connect it to a USB 2.0 Port? I didn't...

    I have a ASRock K7S8XE+ Board. And U?

    When I try to install the driver manually with device-manager it wont use the downloaded driver...

    together we are strong ;o)
  6. Sleeper

    Sleeper TS Rookie

    Problem solved!!

    Hi Ross,
    in my case the solution was to plug the Card on a USB 2.0 port.

    My board (ASRock K7S8XE+) officially supports USB 2.0 but it had problems with the card.
    A very friendly guy from the hotline sent me a special USB-driver.
    Installed and :grinthumb it rocks

    Hope this solves your problem too...
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...