AVI to HDMI from Nvidia GeForce 6600 GT not working on TV

By macx
Jan 28, 2011
Post New Reply
  1. XP sp 3

    NVIDIA GeForce 6600 GT which has (1) AVG output and (1) DVI output

    Trying to display over a Samsung LCD tv with HDMI port, am cabled per the tv instructions

    So far only showing PC as the Source and a comment that says "check cable" on the tv

    I checked in Display and there are ony 2 options

    #1 is "Plug n Play Monitor"
    #2 is "Default Monitor"

    Has no effect to change from #1 to #2 or turning off the regular monitor.

    Do I need updated / different drivers, or?

    I would think being the NVIDIA has the DVI port, it should send signal thru that.

    I would hope I could display over the tv without unhooking the VGA cable every time.
    (Haven't tried that yet, will after this post)

    It would be convenient if I could display over both simultaneously, as the tv is in another room and it would be nice to be able to start the movie over the pc using the regular monitor to set things up and get it started.

    Thanks for any help!
  2. macx

    macx TechSpot Maniac Topic Starter Posts: 738

    Well, I think I finally solved the problem.

    Did a general Search for related topics, saw some posts talking about the same problem, one of them mentioned something about drivers, altho in too technical terms for me to understand what it all meant.

    Being I installed the card when I built the machine several years ago, I realized there probly would be updated drivers available.

    Went into the NVIDIA website and there was a new driver that covered a number of their cards incl apparently all the new ones, was just released this month.

    Downloaded (large! something like 50+ mb) and ran it - it installed itself.

    NOW I have an NVIDIA setup icon in the task bar that includes dual view and all kinds of setting
    for running 2 monitors.

    It recognized the tv, recognized the type of hookup / cable, but still nothing on the tv itself.

    My wife played with it and went into Input and found that there is a separate input setting for
    HDMI and PC. Switched it, now it actually works!!

    So for other NVIDIA 6600 and other series owners, by all means install that new driver from the
    NVIDIA site. Super control panel with it!
  3. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,285   +155

    Good job macx (to you and your wife!) and thanks for the solution and update :)
  4. jobeard

    jobeard TS Ambassador Posts: 13,042   +224

    Assume this was a TV setting???
  5. macx

    macx TechSpot Maniac Topic Starter Posts: 738

    Yes, my apologies.

    There's a menu on the tv with a number of settings and, not being "friendly" with remotes, hadn't really explored it other than changing source from TV (either cable or air) to PC, and that was when I was hooking to a different Samsung LCD with a VGA cable.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.