TechSpot

Bad lag when trying to play games

By rahduh
Mar 19, 2005
Topic Status:
Not open for further replies.
  1. I have been having problems playing games on my laptop in singleplayer and multiplayer because of lag. I know its not my connection, but I have no clue of what it is. I did a sys. restore and it fixed the problem so I then decided to reinstall windows xp since I thought the problem was fixed. After I did a complete reinstall of a new xp partition, the lag came back. I have updated drivers, defraged, and everything else that I can think of, but I still have problems with lag. I even put all the setting on the game down to low and now I am running in a 800x600 resolution and I used to run in 1078x800. The game usually runs good for about 15 or 20 minutes when the computer is first turned on and then after that it starts to lag in graphic intense areas of the map. When the computer has already been on for a while it lags from the start of the game. I have also noticed that the maps load a lot slower than they used to also. When it does lag it also makes my ping jump too. Another thing I have noticed is when I get in close quarters with someone and we start firing at each other and it starts to lag then also. I don't know if it is my vid card or not cause I never had this problem before but it is an onboard intel 64mb vid card. As far as I know, my computer is updated as much as possible unless I have somehow missed something.
    Game:
    Medal of Honor Allied Assault

    One other thing is in the start menu under medal of honor, there is a program called EAsy info and it checks the computer to see if it meets the requirements for the game, and it says that my cpu speed is in the -1900 range. Then when I check my Spearhead expansion pack, the cpu speed is 2391. Don't know why this is.

    Computer specs:
    2.4 processor
    1g ram
    64 intel onboard vid card
  2. cloudt88

    cloudt88 TS Rookie

    Anyone pls help!!..
    i m having the same problem as well....when i was playing games for about 10 to 15mins, my laptop lag...
    I tried to reformat for several times but the problem still exists...I m using wireless network connection to the router.....sometimes when it lags, my connection will disconnect and cannot reconnect back....i have to restart my laptop....

    centrino 1.6Ghz
    512 ram
    radeon 9000 64mb
    all drivers and OS are updated...

    Thanks!
  3. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,763

    Both sound like a heat issue. Make sure the fans arent clogged with dust.
  4. cloudt88

    cloudt88 TS Rookie

    ok....thanks....i will try to clean it and see how it goes...
    anyway, forgot to mention that my laptop will lag after 10 to 15mins i play the games....it will last for about 1 to 2 mins then will return to normal.....
    however, after 10 to 15mins later, it will lag again.....the situation continues as long as the game is on....after i off the game, the laptop seems ok..
  5. compguy

    compguy TS Rookie Posts: 162

    Usually I'ts the game that lags!!!
  6. momalyd

    momalyd TS Rookie Posts: 26

    hi. if its not a heat issue then it could be a spyware issue, i found adaware se is a good anti-spyware, it catches a lot of undetectible reacuring spyware like like varients of vx2. its free but i do have too run it once at start up just before running a game. and noadware is also a good one, run it once evry week or 2 and you should imrove, if only slightly
  7. kol_indian

    kol_indian TS Rookie Posts: 368

    another possible cause of the problem might be nay RAM freeing software that u might be using i saw this being the problem for ateast couple of people with simmilar problems, best solution is to disable this software when playing the game. :)
  8. compguy

    compguy TS Rookie Posts: 162

    Yeah I think you are putting your srcreen resolution A bit to high :grinthumb try lowering it to the,lowest reoslution. I've had the same problem. :knock:


    Sebastian
  9. Panzer

    Panzer TS Rookie

    Mouse Lag when at menus

    Just yesterday my I tried playing a game (Black Hawk Down: Team Sabre) and the mouse was lagging at the menu. So i tried playing but there was way to much lag. This was the first time this happened. Then I tried a different game (Warcraft 3: Frozen Throne) and there was the same problem.
    I have no clue what is going on and I need help really badly.

    I am your father
    - Darth Vader
  10. momalyd

    momalyd TS Rookie Posts: 26

    if the games worked previously and you are on the net, mostlikey broadband. then you could have a spyware and addware problem, you can download anti-spyware software trial versions for free, try 3 or 4 difffrent types of removers. adaware se has a good fast scan and it will show you whats infected, but i recently got ewido suit, which was excelent, it cleaned everything but it doesnt tell you what virus's it removed
  11. luv2playcs

    luv2playcs TS Member Posts: 73

    Hmm.

    When u play the game,he screen resolution changes cause when u reformat windows,Windows XP knows your Graphic card brand,

    solution

    install the real graphics software,not the microsoft drivers!
     
  12. GAM3R

    GAM3R TS Rookie

    same problem

    Hi,

    I've been having a similar problem. I play Halo for PC and my computer handles the game really well. However, when I play Halo multiplayer over the net I continually experience lag. Frequently (about every 10-30 secs - varies) I just stop moving and a little icon with a cross through it appears in the lower right corner of the screen. Then, a few seconds later I start moving again and all the actions I made while immobile happen so everything is jumpy for a few secs afterwards. This is really frustrating as I can't aim or play properly.

    Any advice would be appreciated.

    Computer:
    pent 4 3.2ghz
    1gb ram
    ATI Radeon X800 PCI Express 256Mb
    1.5mbps/256kbps connection
    connected over a wireless home network
  13. N3051M

    N3051M TS Rookie Posts: 2,800

    Describe the icon please.
    Do you have any background apps that pops up a message once in a while (similar to what you get when someone messages you on MSN)? and try disable them.
  14. GAM3R

    GAM3R TS Rookie

    The icon appears to be a picture of a computer with a cable plugged into it (similiar to that Local Area Connection Icon in the Network Connections window) and then a red cross through it. Sometimes when i play it comes up and i am immobile for about 30% of the time. I usually just quit. However, other times i play and i only experience slight lag with the icon appearing only half a dozen or so times in an hour long multiplayer match.
  15. N3051M

    N3051M TS Rookie Posts: 2,800

    can you get anymore info on that particular icon? try right clicking it or double clicking it and see what program it belongs to.. maybe you can disable it, or if its a system message or a particular nastie... Check task manager as well..

    does it happen only while playing or general internet use as well?
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.