TechSpot

BAD_POOL_CALLER (and HEADER)

By Jake2
Sep 26, 2009
  1. Hello, first post on here. Looking for help please.
    Desktop pc has recently begun showing Blue screen and rebooting whenever certain programs or activities are attempted.

    Whenever I try to open Creative X-Fi I get
    BAD_POOL_HEADER
    ***STOP: 0x0019 (0x0020,0x894D3DA8,0x894D4478,0x88DABC90)

    Intervideo WINDVD4, causes
    BAD_POOL_CALLER
    ***STOP: 0x00C2 (0x0040,0x0000,0x8000,0x0000)

    Any game or music cd placed in the cd dvd drive causes,
    BAD_POOL_CALLER
    ***STOP: 0x00C2 (0x0040,0x0000,0x80000,0x0000)

    I'm not that clued up on computers so this is a bit over my head. Can anyone please tell me how to fix this-in very simple language, as right now I cant play games at all on this pc.
    Thank you in advance for your help.
     
  2. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

    0x000000C2: BAD_POOL_CALLER
    A kernel-mode process or driver incorrectly attempted to perform memory operations. Typically, a faulty driver or buggy software causes this.

    Two Questions:

    1. Have you downloaded any software recently? (Also, how are your internet habits?)

    2. Have you scanned for infections?
     
  3. Jake2

    Jake2 TS Rookie Topic Starter

    Scanned for spyware and virus all clear
    Only downloads I have done are to update the drivers on the soundcard and the graphics card. I think this may have been the start of my problems.
    Here are the error codes and times:

    There are error codes in the system log files: It seemed to get much worse after 24/09/09. No errors logged before 24/09/09.
    10005- since 24/09/09. 17.56
    7023-since 26/09/09. 90 times 26/09/09 15.43 (Removed Nero 7 and installled nero 9)
    10005-7001,7026. 24/09/09 21.56-21.58 (Updated creative software)
    7000- 26/09/09 21.39
    9- 26/09/09 15.32

    I think its connected with the soundcard but I'm not certain.

    **UPDATE
    I disabled the soundcard in device manager and I got NFS underground 2 to load and play. I couldnt test the cd playback as there is no sound and media player does nothing (obviously)
    Win DVD opens up ok. So now I'm more convinced that its the sound card.
    What do you suggest?
    Uninstall all creative components and reinstall? I couldnt see an uninstal option in the creative folder in the program list, whats the safest way to remove this and start again?
     
  4. Jake2

    Jake2 TS Rookie Topic Starter

    Ok so I unistalled the creative sound card, including removing the card. Then booted up again and installed the card from the disc. Everything works fine now!! VERY relieved!
    The thing is. The creative site lists about four or five critical updates for this set up, bearing in mind I think this was the start of all the trouble.
    Should I try updating again, (incase i was a bad driver load, is that even possible?) or just leave it alone?
     
  5. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

    Good diagnostic work! Here is the rule on drivers: If it ain't broke don't fix it. Seriously, if your sound card is working as you need it to leave it alone. Creative has a none too good reputation on their drivers and driver support.

    * Let us know if you continue to have stability.
     
  6. Jake2

    Jake2 TS Rookie Topic Starter

    Played NFSU2 for about two hours with every graphics setting on maximum. Then the game crashed to the desktop,:( no blue screen!

    Its done this a couple of times before. Luckily I had speed fan running in the background.

    It showed that the GPU was at 69 degrees with a symbol that I can only assume meant it stopped because of high temperature.
    Does the GTX 275 not adjust the fan to compensate for high stress? Can you tell me what temp this card should cut out at? What can I do about this?

    I think I will assume the driver was the problem and is cured.:D I will follow your advice Route44 and leave the drivers alone.
     
  7. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

    Well consider the following: 69 degrees Celcius = 156 degrees Farehnheit! Is the fan running on your video card? How is the overall air flow in your system? Heat issues will shut down a system fast because the system is trying to prevent damage.

    Keep in mind that when you game you are putting a load on your video card and thus increasing the heat output. Since games are very demanding of the GPU this heat increase is the norm for your video card, but your temps seem beyond the high range maximmum.

    Google your video card and specifically look for heat parameters. Go to Nvidia's website and do a search for your card and see what they say. Also, check out their forums.
     
  8. Jake2

    Jake2 TS Rookie Topic Starter

    Thanks again for your advice. I'll have a look at Nvidia.
     
  9. fimbles

    fimbles TS Evangelist Posts: 1,160   +198

    69 celsius is not hot at all for your card.

    I have it from the mouths of BFG themselves ( bfg gtx 275) that normal operating temp is around 75 degrees under load. And temp threshold is an astounding 145 celsius!!

    Strangely enough the gtx 275 fan never seems to increase its speed at all, it just sits at 40%.
    If you do want to increase your cards fan speed use "EVGA precision" which can be downloaded for free. yes it works on non evga cards too!

    In my opinion its most likely to be a software conflict as a pose to a hardware problem.

    Hope this helps. :)
     
  10. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

    In light of what fimbles has posted, what version driver do you have? Is it the latest for your video card?
     
  11. Jake2

    Jake2 TS Rookie Topic Starter

    Route44:
    GTX 275 driver 6.14.11.9062
    It seems to be the latest one.

    fimbles:
    I downloaded riva tuner and set up temperature controlled fan speeds. I dont know if this is the same as EVGA precision or not. Is one better than the other?

    The fan does now change speed now as the gpu core gets hotter, I ran furmark 1.6.5 a few times to build up the heat and running it continuously the temp got up to around 70 degress with the fan going to 80% at 66 degrees. With no BSoD.
    However the computer was connected to a vpn via the internet and while at idle it BSoD again. :mad:

    Riva tuner, furmark and some video codecs have been added, since I thought the BSoD problem was fixed. Today was the first BSoD.
     
  12. Jake2

    Jake2 TS Rookie Topic Starter

    Hello,
    I removed rivatuner furmark and anything else I had added but nothing changed since the last update.
    It seems this problem is not corrected, nor am I alone with this one.
    The error log shows up in one of the rofiles on the pc.
    EVENT ID 1001
    "The computer has rebooted from a bugcheck"
    Weird thing is it appears to happen at the same time every day!
    I have had a look around the net for soloutions but all I've found is lots of people with the same problem. Various souloutions suggested "bad ram, drivers, hardware etc"
    How can I isolate the cause hardware/software/driver?
    Can anybody suggest a soloution? Turn off bugcheck maybe?
     
  13. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

    It could be the card architecture itself but we have no way of knowing. Does Nvidia address this issue anywhere considering many people are having the same issue?

    Are there any older drivers you can roll back to?
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...