Battlefield 1942 multiplayer problems

By sw123
Mar 25, 2006
  1. Hello.

    I recently got an upgrade for my computer so I could play more games, and one of those games is Battlefield 1942. I wanted to play a multiplayer game on Battlefield 1942, but then it said "failed to connect to server". I disabled all my firewalls and antivirus protection, but still the same thing. I checked my internet connection, and everything was good. Is there a way to solve this problem? My system specs are in my profile, but for convience, I will put them right here:

    eMachines T2682(upgraded w00t!)
    Intel Celeron 2.60 GHz Processor
    Intel 845GV Motherboard
    768 MB DDR SDRAM
    PNY FX5500 128 DDR PCI Dual VGA
    Creative SoundBlaster Live! External USB 2.0
    Realtek 10/100 MBps Ethernet card
    Western Digital Model WDC800EB-11DJF0

    My system is capable of Battlefield 1942, and I have no problems playing it in single player.

    So, could it be my Ethernet Card? Also, I have SBC Yahoo! DSL and when I download stuff, I get about 160 KB/sec, I assume this is the DSL speed.

    Thanks for replies in advance!
  2. Akifuddin

    Akifuddin TS Rookie Posts: 144

    Go to My Computer, then My Network Connections. then View Network Connections, then disable your connection, enable it, repair it, restart your computer, repair it again and try re-connecting and playing.
  3. sw123

    sw123 TS Rookie Topic Starter Posts: 595

    I dont believe that will work. (no offense) Considering I can still browse the internet, and I really dont like disabling my connection because it screws up my DSL modem and my router. Is there an alternative?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...