TechSpot

Battlefield 2 Demo on GE Force 5200

By Murdock
Jun 18, 2005
Topic Status:
Not open for further replies.
  1. I Downloaded the bf2 demo on my computer, but i'm experiemcing a major problem. I can't play on any server, everytime I try to join a server, it takes me back to the server list before it even starts to load. Heres the weird part, If my video card is the problem, how come i have no trouble playing the single player version? I know people have trouble running this game on GE Force 4's, But I have a 5200. I Don't think it's my video card, and i don't have a wireless connection, i'm connected directly to the router. I've tried everything, from running spyware search hand destroy, ad-ware, ran avg, no virus detected, no spyware or adware as well. I've tried getting rid of the anitvirus, and turning off firewall, but i still can't play online. Any suggestions? Please help. Thanks.
  2. PaulWuzHere

    PaulWuzHere TS Maniac Posts: 378

    I think I know

    It says in the read-me for BattleField 2 that the FX 5200 isn't supported (why you can play single player, I do not know) Maybe the servers don't know what it is lol. Plus the 5200 is a good budget card but Battlefield 2 is a monster. I do miss my 5200... it was quite :D
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.