TechSpot

Belkin Wireless G Desktop Card problems

By Willis
Jul 4, 2008
  1. I recentely had to fix my little brother's computer and got it all done, but I didn't have the disk for the Belkin Wireless G Desktop card; My little brother had scratched that up and was no longer readable. I remember that I, once before, had to download the drivers online to get them installed, but cannot find them now.

    I was wondering if anyone here could help me with this problem. I have the same card in use on my PC and it is using the BLKWGD.sys file(version 4.1.2.56).

    Would there be any way for me to transfer that to his computer somehow, such as burning it to a CD?
     
  2. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

  3. Willis

    Willis TS Rookie Topic Starter

    The problem with that is that it takes me to a page with drivers v1xxx through v7xxx. I do not know which to download, I've already gotten 3 of them, but they failed to work. I got version 1xxx; Didn't work. I got version 4.000; Didn't work. I got version 7xxx; again, no surprise here, didn't work.

    The product number of it is F5D7000, if that helps at all... I need the driver version 4.1.2.56.
     
  4. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

  5. Willis

    Willis TS Rookie Topic Starter

    I've already tried that one, failing results...

    I don't know what else I might be able to do.
     
  6. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    I have the same card in use on my PC
    Use DriverGrabber to get your driver backed up
    Then write it to CD

    Install it on your little brother's computer
     
  7. Willis

    Willis TS Rookie Topic Starter

    I got that all done and it finally recognizes the driver as the one that is needed for it and it is all well aside from the fact that now, whenever I try to install it, it gives me a Parity Error, stating that there has been a hardware malfunction and the system is halted.

    Any Ideas on this?
     
  8. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Start -> Run -> devmgmt.msc -> OK
    Remove the Belkin Wireless G Desktop Card
    Shutdown
    Unplug the card
    Restart
    Run Driver Cleaner

    Shutdown
    Re-insert the Belkin Wireless G Desktop Card
    Startup
    Put the driver disc back in

    Point the found new hardware to the drivers disc
     
  9. Willis

    Willis TS Rookie Topic Starter

    That worked, thank you so much.
     
  10. DragonRyder

    DragonRyder TS Rookie

    any chance you can give me a link to that driver you found - i need it for my cousins pc
     
  11. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

     
  12. DragonRyder

    DragonRyder TS Rookie

    and nothing @ that site works for this - heance the reason i asked him what driver did he grab exactly that worked
     
  13. Alty

    Alty TS Rookie

    I have the problem and need to know the same thing. Willis which driver was it that you burned to CD?
     
  14. Alty

    Alty TS Rookie

    OK I'll make myself a bit more clear because I can't seem to solve this and really need help. I reformated the harddrive of my mums computer to make it run faster. I've just finished re-installing windows. The computer already has this particular wireless network card in it. I couldn't find the CD installation anywhere so I downloaded the latest driver on the Belkin website and transfered it to my mums computer on a external hard drive and installed it on there. Howeveer once the installtion is finished the application is really faulty because a lot of the command buttons are greyed out or they do nothing when clicked and some of the pictures are missing etc.

    I thought this was because I was missing some dell drivers (the computer is a dell), so I uninstalled the driver and downloaded the network dirver from the dell website. I then re-installed the belkin driver but still had this problem. I tried about 4 other versions of the belkin driver from the website but they all had similar problems. The most useful was the V1 driver which came up with an error message when I try and open it saying:

    "Incompatible driver version found. Unable to load application."

    Please help me I will be so grateful!
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.