Belkin wireless router

By trish44
Mar 5, 2008
Topic Status:
Not open for further replies.
  1. took the belkin back and they gave me a dynamde, works with one Laptop ireless, the other tel me it is conect but get the usual message cannot connect to the network, try looking at your connections , losig the will to live
  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,456   +288

    Try a firmware update, and or change the wireless channel to either 1 or 11.
  3. trish44

    trish44 Newcomer, in training Topic Starter

    have it at 1 so will try changing it to 11, also only bought it last month, would it need a firmware so quickly
  4. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,456   +288

    Hard to tell, take a look at what firmware its running on its setup page. I would imagine its possible that router was made a year or 2 before you actually bought it, in which case it would have an old firmware.

    I know I updated the firmware on my Belkin a couple weeks ago, I bought it back in August 2007, it was running firmware from October 2006. Latest was December 2007.
  5. trish44

    trish44 Newcomer, in training Topic Starter

    changed the channel to 11, however when i went to find the firmware the serial number (base of router) was not recorded on belkins site. Tried to email them to no joy
  6. singapork

    singapork Newcomer, in training

    was wonderin, are u using dsl connection or cable?
    It could be the cabling from router to ur modem.

    and can any other laptop access ur current belkin wireless?
  7. trish44

    trish44 Newcomer, in training Topic Starter

    using dsl, other laptop is fine and the desktop is fine, howver when i try to connect office laptop, it makes the other laptop drop out, also the version number is from 2004, tried to load the 2006 version to no avail
  8. singapork

    singapork Newcomer, in training

    If u have updated your firmware and still have the same problem, it might be the configuration of your router and your modem.

    I was wondering whether
    your DSL modem is configured to Bridge mode?
    your router connection type is configured to PPPoE?
  9. trish44

    trish44 Newcomer, in training Topic Starter

    none of the above, it now also doesn't allow access for games consoles so i think maybe i need to take this back to the shop
  10. trish44

    trish44 Newcomer, in training Topic Starter

    Dynamode r-adslc4-w-g1

    had a belkin router that the shop eventually admitted was not working , they have now given me a new dynamode, can load up my office laptop my other machines show conectivitiy but when i try to access a page it says there is a problem with my internet.

    Has anyone any ideas as the shop are not very helpful
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.