TechSpot

"Bios checksum error" after keyboard / mouse lockups

By nissanman
Apr 28, 2009
Topic Status:
Not open for further replies.
  1. Hello.

    Been having very, VERY annoying issues with my computer as of late. I could be playing a game. All is well until all of a sudden my keyboard and mouse just completely stop working (although the computer still appears to be running fine, just keyboard and mouse stop). So i restart my computer, only to get a message along the lines of "bios checksum error" with very fast, constant beeping. I reset my computer again and i get nothing on my screen, the light just turns amber. After turning my computer strait off and back on again, it comes back to life and begins working again like nothing ever happened. (until the next time it happens).

    I am really struggling to find out what the problem actually is, but i THINK that it might be the motherboard, but im not sure. What do you guys think? Sound like a motherboard problem?

    My system specs are as follows:

    CPU: Pentium 4 2.2Ghz
    RAM: 1GB DDR400
    Video: GeForce 6600GT
    HDD: 320GB WDC
    Mobo: ECS 661FX-M (I know ECS is crap, this is why i think it might be the mobo)
    PSU: Thermaltake 430w
  2. fastco

    fastco TS Rookie Posts: 1,511

  3. nissanman

    nissanman TS Maniac Topic Starter Posts: 362

    ok, i appear to have fixed the problem now. I think my Northbridge was overheating. It use to have this really bad (seriously, the stuff turns to powder after a week) thermal grease but i replaced it with high quality silver thermal grease. Seems to have done the trick. Yay! :)
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.