TechSpot

BIOS not detecting one of my hard drives

By d131lo222
Feb 19, 2011
Post New Reply
  1. Hey guys,

    This has been a frequently reoccuring issue. At the moment I have two hard drives I use on my 10 month old computer. Everytime I shut down my computer and try to reboot it I recieve and error message similar to "Reboot or select proper Boot device or Insert Boot media in selected Boot device and press a key". When I open BIOS to check on the issue one of my hard drives is never dected, but the other very frequently is (sometimes neither are detected).

    To solve this issue I have been powering down my computer for about 30 mins then I'd try again in the hope that it would detect both that time. When they both have been successfully detected I then have to navigate my way to Boot>Hard Drives then swap the 1st hard drive with the 2nd so on Boot>Priority the 2nd is the one showing. However, the 2nd hard drive that I speak of is the one that is rarely detected. This is rather frustrating at times and I would like to solve the issue as soon as possible as it seems to be getting progresively worse.

    I currently don't have any external hard drives plugged in. I have swapped the hard drive cabels around from hard drive to hard drive (I tried unplugging/re-plugging first) and the issue is still occuring.

    Any help or suggestions will be very much appreciated. If you would like further information I will try my best to answer.

    Thanks,
    d131lo222
  2. mike1959

    mike1959 TS Addict Posts: 1,060   +19

    Is this a Windows XP O/S system?
  3. d131lo222

    d131lo222 TS Rookie Topic Starter

    Windows 7. 64bit
  4. mike1959

    mike1959 TS Addict Posts: 1,060   +19



Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.