TechSpot

BIOS screen won't show up

By xxhieixx
Aug 17, 2007
  1. I made a thread earlier called monitor stopped working but found out that wasn't the issue. Anyway, I moved my room around Wednesday evening and then on Thursday when I turned my PC on the monitor light remains orange and nothing will show up. Then after a few minutes my desktop shows up with three icons and no task bar. I tried right clicking and going to properties but it wont work, I can't get anything to show up except when I clicked on one of the folder and went to "open with..." I tried putting in the recovery disc but that won't show up either. So then I tried bringing up the bios but the monitor light remained orange and the screen stayed black. When I turned the hard drive off after this it went off as soon as I touched the power button so I think it was up I just couldn't see it. So can anyone help me with this?
     
  2. ani123

    ani123 TS Rookie Posts: 113

    u may try this: just remove your pc clock battery(on the motherboard) and then again place it in the same position,u will again see your bios.
     
  3. xxhieixx

    xxhieixx TS Rookie Topic Starter

    I removed the battery and put it back in and tried to get the bios up but it still didn't work. When I hit F2 it beeped a few times and then stopped but it still stayed black. I'm going to leave it on for a few minutes to see if anything shows up and if not I'll try again.
     
  4. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,714

    Did the case get dropped or anything in the shift around? Check all connections for bent pins.
    Unplug everything from the back of the PC except the power, keyboard and monitor. Reboot.
    One beep is good, many beeps not so good, no beeps is bad.
    What do you get?
     
  5. xxhieixx

    xxhieixx TS Rookie Topic Starter

    I don't think it got dropped, my hubby was the one who unplugged it and moved it, I'll have to ask him about it when he gets home from work. I looked for any bent pins and everything seems fine. I only plugged in the monitor, keyboard, and power but I still get nothing. Whenever I hit F2 it beeps for awhile and then stops but nothing will show up. I tried taking out the battery again too but I still get nothing.
     
  6. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,714

    I am sorry but I think this requires some surgery. It may be that by moving it you have disturbed something and the most likely candidate is the graphics card (if not an on board one).
    Take the lid off and check that the card is pushed firmly into the slot on the board and see if it will start While you have the lid off, turn it on and make sure the fans are running on the CPU and inside the power supply.
    Let us know
     
  7. xxhieixx

    xxhieixx TS Rookie Topic Starter

    All the fans seem to be working along with the graphics card. I think when I pick up my hubby today I'll drop off my hard drive where he works at and they can tell him about it tomorrow, hopefully it won't cost to much since I'm planning on getting a new one soon anyway. Thanks for all the help.
     
  8. xxhieixx

    xxhieixx TS Rookie Topic Starter

    Well I got it to work, I had to plug it into the graphics card (and I feel stupid now). I was going to do this earlier but I had the screws in wrong and I didn't need to plug it in that way before so I just ignored it. So while I had the lid off I fixed the screws and decided to try it and the screen showed up and every thing's running fine now. Thanks again for all the help, I appreciate it and sorry for wasting your time, I should have tried this before I even posted about it.
     
  9. Po`Girl

    Po`Girl TS Rookie Posts: 668

    ___________________;)
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.