TechSpot

Bioshock black boxes?

By Sketchy Meister
Feb 22, 2009
  1. Bioshock black boxes? (fixed)

    I just started playing Bioshock a couple of weeks ago, and i get black boxes showing up...everywhere. I even just started getting X's! I don't know what is causing it and im wondering if anyone has any ideas? i have the most recent nvidia driver and bioshock patch 1.1. Also, when i start up, the intro stuff plays in the background but the video portion of it is stuck on the first copyright thing. It will go to the menu correctly after i hit escape after the nvidia sound.

    [​IMG]

    Edit: I had reinstalled it, and it worked fine for awhile. Then the same thing started happening after a day or so.
     
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,915   +167

    The video card may be overheating or just plain going bad
     
  3. Sketchy Meister

    Sketchy Meister TS Rookie Topic Starter Posts: 32

    I doubt it, its only about 6 months old, and i have the fan all the way up. And this is the only game its happening to :(
     
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,915   +167

    Your specs are good. I had problems with the Creative XFI Extreme Gamer in my Vista computer. I trashed it in favor of my on board sound, which was much better. I wonder if it is conflicting with Bioshock
     
  5. Sketchy Meister

    Sketchy Meister TS Rookie Topic Starter Posts: 32

    Hm, well i haven't had any problems with my X-Fi. I absolutely love it, and going from on board to this, i noticed a huge difference! But could a sound card really create visual artifacts?
     
  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,915   +167

    "But could a sound card really create visual artifacts?"

    I really don't know, but it might be worth a try to use the on-board sound to test this theory. I have seen sound card difficulties cause video "studdering" or pauses, but not visual annomalies
     
  7. Sketchy Meister

    Sketchy Meister TS Rookie Topic Starter Posts: 32

    I fixed it. I just turned off the high detail shaders. Must be a 64 bit thing?
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.