TechSpot

Black screen after ATI card install

By kburcham
Nov 11, 2010
Post New Reply
  1. I have a HP Pavilion 502n Desktop. Memory is maxed at 512 mB. I am trying to install a new video card (ATI Radeon 9000 - PCI), and after installing and rebooting, my PC beeps at me 3 times and the screen says there is no input, either VGA or DVI, and goes black. I tried to disable the onboard video before installing and I get the same behavior. Is it a compatability issue? The motherboard has 3 PCI slots. Thanks.
     
  2. mailpup

    mailpup TS Special Forces Posts: 6,980   +362

    Try another PCI slot or maybe the power supply is inadequate to power the new card.
     
  3. kburcham

    kburcham TS Rookie Topic Starter

    Thanks for the reply mailpup. I did try another PCI slot and got the same response. I don't recall the video card stating any special needs for power, but I will do a little more research and check that. There is no cable for connection of additional power from the motherboard.
     
  4. mailpup

    mailpup TS Special Forces Posts: 6,980   +362

    The power requirements of the new card don't have to be special. It just might be that the combination of age and slightly higher power draw is too much for a marginal power supply. That said, I don't know for certain it's your power supply and I have no information about yours It's just something to check.

    Another possibility is the card is defective.
     
  5. kburcham

    kburcham TS Rookie Topic Starter

    dear mailpup,

    will check the power supply tonight; thought about the card being defective too. Thanks.
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...