TechSpot

Black screen when playing games

By razaelya
May 18, 2008
  1. I have a Emachines T6212 with ATI raedeon 2600 video card w 512 mb, and 1.5 gigs of ram. I have been getting a no signal input and then a black screen from my monitor while playing WoW and AoC.

    I have systematically done everything I can think of to solve the problem but was hoping maybe someone else might have other ideas... this is what I have done.

    . Checked and updated all drivers.
    . Upgraded the powersupply.
    . Upgraded the video card.. this solved the problem with WoW but not AoC.
    . Checked and updated Drivers again.
    . Got a new VGA cable for the monitor.
    . Got a new monitor.
    . Cracked the case for airflow.. Nothing is hot in there.
    . Cleaned it with compressed air.
    . Set to optimal settings in Bios
    . Changed MSconfig to only run needed programs.
    . Ran a registry cleaner, diskcleaner and defragger... I'm doing whatever at this point.

    Please any other clues as to what might be causing this, I really don't want to have to buy an new comp.
     
  2. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 5,429   +27

    Have you checked your RAM? Run memtest for 6-8 passes on each stick to see if any of them is faulty.
    Also, have you tried flashing your motherboard's BIOS to the latest version?
     
  3. czarh

    czarh TS Rookie

    I have the same problem:( with the same video card

    If nothing ends up working my reccomendation is to get a refund on your 2600 and go buy a new card, possibly an nvidia 7xxx series or an ATi 3xxx series
     
  4. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Are you sure the game's screen resolution and refresh rate is set to something the monitor can handle?
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...