Blank icons after Vista/7 upgrade

By Doctor John
May 24, 2012
Post New Reply
  1. I have just upgraded a laptop from Vista Home Premium to Windows 7 Home Premium (both 32-bit), installation proceeded ok, but now all icons (desktop, menu, etc.the lot!) are blank and right clicking them doesn't work at all, left click only works on a few of them.
    I have tried deleting/rebuilding the icon cache, no help.

    Any ideas, please?
  2. Doctor John

    Doctor John TechSpot Enthusiast Topic Starter Posts: 247   +15

    Now I have also found that the icons are normal and fully functional in safe mode, but no combination of clean booting/disabling services/disabling startups will persuade them to behave in a normal desktop!
  3. mike1959

    mike1959 TechSpot Addict Posts: 1,039   +15

    Hi, In 'safe mode' your pc is not using your Graphics card in the high res mode you normally use, so I would have a look at your Graphic card driver. Possible your Vista driver is still being used and you would need to uninstall it and get the Win 7 version for your graphic card.
  4. Doctor John

    Doctor John TechSpot Enthusiast Topic Starter Posts: 247   +15

    Thanks for the quick reply - I tried replacing the graphics drivers, no joy. I've since done a clean install, so problem solved.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.