TechSpot

Blank screen on start, then working perfectly again

By arkaf
May 10, 2009
  1. Hi, I have an emachines M622-UK8X. It is about 2 or 3 years old. I never had any problems with it although I use it a lot. The only thing I had noticed before is that it heats up a bit, but it never became a problem.
    I take it with me to work each day and as I said it is on every day.
    Last week, I had it with me at work. Everything was functioning perfectly. I think I turned it off when I left and when I came back home I turned it on and the screen wouldn't work. It was just black. All the led lights were on and I could hear it running but the screen showed nothing. I could open the cd tray, and there would be more running if I clicked enter.
    The display on the screen had been perfect at work, no signs that something might be going.
    One of my friends told me that the same thing happened to her and that when she took out the battery and used it only connected to the ac, it started working again, so I tried it and it did work. I was able to work on it for the rest of the day, again with no problem at all and perfect display/great image.
    I thought that the problem was solved and made a note to get a new battery although I rarely use it in battery only. I always have it plugged in.
    I turned it off at night and didn't worry anymore. However the next day when I turned it on the same thing happened again - I still didn't have the battery in - .Led lights were on, I could hear it running, but nothing but a black screen.
    I had to turn it off by pressing the power button again since I couldn't see anything.
    I tried one or two more times. Nothing.
    Then I moved it around a bit, turned it upside down to see and my husband took the screws to see if there was anything in special that looked out of place inside. He didn't do anything other than taking a look inside.
    But when I turned it on again, it was working. Again nice bright screen, everything working perfectly.
    Now I'm even scared of turning it off, I don't know what will happen - will I have the screen working or not? Can't even guess.
    When the screen was black I tried to see if there was anything at all no matter how faint showing, but it didn't seem to show anything at all, just black.
    Is there anyone in here who had the same problem and was able to fix it?
    Any ideas and help would be appreciated, I am really at a loss and really worried about turning it off today.
    Thanks
     
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    The power supply would be the first thing to replace for this
     
  3. arkaf

    arkaf TS Rookie Topic Starter

    So it can be the power supply? I never thought of that but I guess it makes sense.
    It has been running fine the last few days but I'm always a bit worried that it will happen again. I still don't have the battery on.
    Going to check the power supply and replace it if it needs, thanks.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...