Blue Screen error Pagefault In Nonpage Area (help please)

By MistaRip
Feb 7, 2006
Topic Status:
Not open for further replies.
  1. I keep getting this blue screen about every hour. Sometimes less.
    I havent installed any new hardware or software. I've ran ccleaner, tuneup utilities 2006, and diskeeper.

    I still get it. Can somebody please help? I've attached my minidump. I don't know how to read it. Thanks

    Attached Files:

  2. tipstir

    tipstir TS Ambassador Posts: 4,578   +76

    Turn off your PC and pull out the RAM, just install half your RAM and test that out. If it does the same, shutdown the system again. Remove the RAM and try using the RAM you had taken out. Test and see what happens? If nothing happens then you know you got bad RAM.

    You should really run a diagnosic program running a dos bootdisc CD and test out things like RAM, VIDEO, CPU
  3. Tedster

    Tedster Techspot old timer..... Posts: 10,074   +13

    run memtest86.
    use your floppy drive. if you don't have one, install one.contrary to popular notion, they're still a requirement.
  4. MistaRip

    MistaRip Newcomer, in training Topic Starter

    i've ran memtest and dft hard drive test


    i've also tested with 1 mem card at a time and i got blue screen with both.

    does anybody know how to read a minidump?
  5. cpc2004

    cpc2004 Newcomer, in training Posts: 2,044

    Hi,

    One miniump is insufficient to determine the culprit. You must zip 5 to 6 minidumps and attach the zip file here. Your minidumps shows that it is faulty rama as the bucket id is 0x50_BADMEMREF_nt!ObpRemoveObjectRoutine+cb and this is the sigh of faulty ram.


    PAGE_FAULT_IN_NONPAGED_AREA (50)
    Invalid system memory was referenced. This cannot be protected by try-except,
    it must be protected by a Probe. Typically the address is just plain bad or it
    is pointing at freed memory.
    Arguments:
    Arg1: bad0b148, memory referenced.
    Arg2: 00000000, value 0 = read operation, 1 = write operation.
    Arg3: 8056c77b, If non-zero, the instruction address which referenced the bad memory
    address.
    Arg4: 00000000, (reserved)

    Debugging Details:
    ------------------
    Could not read faulting driver name
    READ_ADDRESS: bad0b148

    FAULTING_IP:
    nt!ObpRemoveObjectRoutine+cb
    8056c77b 833800 cmp dword ptr [eax],0x0

    MM_INTERNAL_CODE: 0
    CUSTOMER_CRASH_COUNT: 1
    DEFAULT_BUCKET_ID: DRIVER_FAULT
    BUGCHECK_STR: 0x50
    LAST_CONTROL_TRANSFER: from 8057f04c to 8056c77b

    STACK_TEXT:
    f78bed64 8057f04c 899e8558 00000001 80567c20 nt!ObpRemoveObjectRoutine+0xcb
    f78bed7c 804e23b5 00000000 00000000 89bfa7a8 nt!ObpProcessRemoveObjectQueue+0x36
    f78bedac 80574128 00000000 00000000 00000000 nt!ExpWorkerThread+0xef
    f78beddc 804efc81 804e22f1 00000000 00000000 nt!PspSystemThreadStartup+0x34
    00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x16


    FOLLOWUP_IP:
    nt!ObpRemoveObjectRoutine+cb
    8056c77b 833800 cmp dword ptr [eax],0x0

    SYMBOL_STACK_INDEX: 0
    FOLLOWUP_NAME: MachineOwner
    SYMBOL_NAME: nt!ObpRemoveObjectRoutine+cb
    MODULE_NAME: nt
    IMAGE_NAME: ntkrnlmp.exe
    DEBUG_FLR_IMAGE_TIMESTAMP: 42250f77
    STACK_COMMAND: kb
    FAILURE_BUCKET_ID: 0x50_BADMEMREF_nt!ObpRemoveObjectRoutine+cb <- faulty ram
    BUCKET_ID: 0x50_BADMEMREF_nt!ObpRemoveObjectRoutine+cb
    Followup: MachineOwner
  6. MistaRip

    MistaRip Newcomer, in training Topic Starter

    ok, i attached a zip with 5 minidumps.

    i tried 6 but it went over 100kb.


    so it's possible that both my mem cards are bad all of a sudden? :(

    Attached Files:

  7. peterdiva

    peterdiva TechSpot Ambassador Posts: 1,202

    Vsdatant.sys,which is a Zonealarm file.Either check for an update or remove to see if problem goes away.
  8. cpc2004

    cpc2004 Newcomer, in training Posts: 2,044

    Hi MistaRip,

    I believe that the culprit is faulty ram. One minidump may be crashed by ZA and your timestamp of your version of ZA is 43798224. I search google and there has no hit relating to this version has known bug. Anyway you can un-install ZA and install sygate firewall for problem isolation.

    Mini020706-02.dmp BugCheck 10000050, {bad0b148, 0, 8056c77b, 0} <-- Faulty ram
    Probably caused by : ntkrnlmp.exe ( nt!ObpRemoveObjectRoutine+cb )

    Mini020706-03.dmp BugCheck C2, {7, cd4, 2060001, 877f28c0} <-- Faulty ram or software error at ZA
    Probably caused by : vsdatant.sys ( vsdatant+3e6e1 )

    Mini020706-04.dmp BugCheck C2, {7, cd4, 2130013, 83cb1538} <-- Faulty ram
    Probably caused by : ntkrnlmp.exe ( nt!ExFreePoolWithTag+2c1 )

    Mini020706-05.dmp BugCheck C2, {40, 0, 80000000, 0} <- Faulty ram
    Probably caused by : ntkrnlmp.exe ( nt!ObpFreeObject+142 )

    Mini020706-01.dmp BugCheck 10000050, {bad0b148, 0, 8056c77b, 0} <-- Faulty ram
    Probably caused by : ntkrnlmp.exe ( nt!ObpRemoveObjectRoutine+cb )
  9. Tedster

    Tedster Techspot old timer..... Posts: 10,074   +13

    run memtest86 overnight for at least 7 passes. what where the results?
  10. MistaRip

    MistaRip Newcomer, in training Topic Starter

    thanks for the help, everybody.

    the problem was zonealarm

    i uninstalled it and haven't had the blue screen ever since

    i cant believe it. oh well.. i just use the firewall on netlimiter 2 and it works fine


    tedster, i did the memtest overnight and got no errors
  11. LIONS*LEADER

    LIONS*LEADER Newcomer, in training

    i got this error code exactly as well for my bluescreen, i also had been having problems with the internet locking up during the night. apparently zone alarm was the culprit. i installed kerio (though i dislike its negative effect on the performance of my computer in comparison) it doesnt have any problems anymore and has not bluescreened since.
     
  12. hardwired

    hardwired Newcomer, in training

    I'm having this same, well i say same, its a blue screen of death Pagefault In Nonpage Area error, but need to zip the minidumps and that really, but how do you do them?

    I need an *****s guide really. Where are they? How do you read them? I need to know everything as i've never heard of them before, please..

    Thanks
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.