TechSpot

Bluetooth malfunctions when language is changed

By pyromaster114
Feb 26, 2009
  1. I have a Toshiba M700 tablet PC running Windows Vista ultimate 32-bit edition.

    I wanted to run a program that requires me to have the non-unicode language set to Japanese.
    I changed it to Japanese, and then proceeded to try and run the program.
    Program runs fine.

    I tried to connect my bluetooth headset to listen to my music. No luck. I get an error message about copy protection.

    What's odd is that if I change the non-unicode language back to English, the headset connects just fine, and it doesn't complain about copy protection or anything.

    Any help on this is greatly appreciated. I have no clue what I'm doing wrong.
     
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    The bluetooth program you have installed is set to work on one user only
    By changing the language it thinks you are another user

    I think ipod software does that too :confused:
     
  3. pyromaster114

    pyromaster114 TS Guru Topic Starter Posts: 246

    If it thinks I'm a different user, how would I fix that?

    Also, here is the error it gives me:
    You cannot connect to a device that is not copyright-protected by SCMS-T method.
     
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    You could uninstall it fully from the original language settings, then install it again under the new language settings ;)
     
  5. pyromaster114

    pyromaster114 TS Guru Topic Starter Posts: 246

    Well, I guess I'll try that...
    But I assume then if that worked if I ever revert back to the default (English) non-unicode settings, then I'd have to uninstall and re-install the bluetooth thing again...
    Oh well I'll give it a try and see if it even solves the problem.
     
  6. pyromaster114

    pyromaster114 TS Guru Topic Starter Posts: 246

    Well, that didn't work... at all.
    The thing still gives me the error about copyright protection.
    I'm starting to think that maybe the driver / manager software has some objection to being run with the non-unicode language set to Japanese.

    If it helps, the problem arises when I try and connect the Audio sink service to the headset.

    I don't know why there's even copyright protection on such a thing... is there a way to disable it?

    If not, is there a way to have just one program run with the non-unicode language set to a different thing than the rest of the OS?
     
  7. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Some of these "bluetooth" programs have their own tech forum
    Although I feel it must be copyright protection only on the installed program not the language file (ie it's difficult to uninstall fully and start again)

    I hope that you receive other replies, because I'm where you are at -> :confused:
     
  8. pyromaster114

    pyromaster114 TS Guru Topic Starter Posts: 246

    Well thanks for trying kimsland...
    This problem is by far one of the stupidest problems I've ever seen.
    I wonder if there's a way that I can tell the bluetooth program (or at least make it think) that the non-unicode language is set to english? I'm going to keep trying...
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...