TechSpot

Boot problem with external hard drive connected

By rduff
Apr 28, 2009
  1. Hopefully someone can help with this problem. I have an external USB hard drive to back up documents and photos, but now the PC refuses to boot if the device is connected. This is a recent problem despite using the same hard drive for some time...it's as if the PC is trying to boot from the external drive which of course doesn't contain the relevant files. As soon as the Windows start up process has begun then it can be connected again. Is this something to do with the Windows boot configuration, if so how do I change it? If it's relevant my operating system is Vista Home Premium SP1.
     
  2. fastco

    fastco TS Rookie Posts: 1,511

    Enter the bios how ever it says to when the computer starts(press Delete, F1, F2 etc) Find Boot or Boot Options and make sure internal hard drive is selected as first boot device. CD or DVD drive can be first but make sure it is not set to boot from external or USB devices.
     
  3. rduff

    rduff TS Rookie Topic Starter Posts: 32

    Problem solved....thanks!
     
  4. fastco

    fastco TS Rookie Posts: 1,511

    Cool, what did you do to solve the problem?
     
  5. REALChicken

    REALChicken TS Rookie

    Had the same problem, searched the Internet and found a million people with the same problem and a million helpful people and their "solutions" to the problem, of which some did just not work, and some were downright dangerous to the health of my PC. But at last I found a solution that works, and it's simple (thank you saykomatrixx):

    First (of course) you check your BIOS to see that USB-devices are below (after) internal HD:s in the boot sequence, and that might be all you need to do.

    If that does not work, or your BIOS (like mine) does not have this option (I only had Disk drives, Hard Drives, Network drives, and Floppy drives), then here's the beauty:
    Find (in BIOS) the "USB Legacy Support", make sure it is set to "Enabled", and voilĂ , it should work like a charm to start-up with the external HD:s connected and on.

    I did get a small surprise during next start-up when Windows started to install drivers for my sound card, and later I had to change some settings in my sound card to get my microphone to work again, as the driver install had changed some settings there, but otherwise everything is just hunky dory.

    Good luck.

    PS
    I don't really know what the "USB Legacy Support" is/does (perhaps a more educated member could tell us?) but as my already was in "Auto" which is a sort of semi-on (software controlled is my guess), the difference can't be that huge from before I switched it fully on.
    DS
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.