Booting problems, motherboard, PSU or CPU?

By Sandcastle
Apr 5, 2011
Post New Reply
  1. So i guess for most of you guys out there you will think this is a basic problem and i wanted to get some opinions/help before dishing out my cash or taking it to a repair shop.

    What has been happening recently is my pc would freeze, make a strange buzzing noise through my headphones or speakers(Whatever i had on at the time) the mouse the keyboard and the screen would all have no signal, i would restart it and it would go back to normal, after about 2 weeks of this happening it started to get worse and finally one day it just died.

    When i try to power my PC up there is no signal to any external components(mouse keyboard or screen). the light on the front is blue and normally has a bit in the middle flickering red, i think this is some sort of link to the motherboard power, but what happens now is it goes red for about 5 seconds then stays blue with no flickering, all help would be great.

    TLDR; Pc won't boot up with no signal to the external components. Light not flickering on the front either.
  2. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

    I would start by testing the PSU. Do you or a friend have a digital multimeter to test it?
  3. Sandcastle

    Sandcastle TS Rookie Topic Starter

    Hey, i don't have one unfortunately. I'm going to take it to be tested today.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...