BSOD after installing new hardware

By TS-56336
Jan 20, 2013
Post New Reply
  1. Hello,

    Two days ago, I've put up a new graphics card (Sapphire Radeon HD 7770) and new RAM (Corsair Vengeance 8gb DDR3 1600 CL10) on my system. I'm using Windows 8 right now. After installing the hardwares, I'm starting to get blue screens more often, even while booting.

    I thought it was just the new Radeon Catalyst 13.1 driver that making it crash, so I installed an old driver version 12 but I kept on getting blue screens.

    So I was tempted to do a formatting of the whole system but unfortunately even upon installation of Windows, the system is still getting sudden blue screens. Even though the fresh install went successfully the blue screens is still a problem.

    I already checked a couple of my RAM settings. I didn't made any attempt to overclock my GPU and Memory yet. But the CPU is stable on its OC setting.

    My specs:

    CPU: AMD Phenom II X2 555 BE 3.2 (Unlocked to Quad core @ 3.8 Ghz)
    Motherboard: AsRock 890GX Extreme3
    HDD: WD Caviar Black 1TB
    (new) RAM: Corsair Vengeance 8gb DDR3 1600 CL10 (single stick)
    (new) GPU: Sapphire AMD Radeon HD 7770 1gb Ghz edition
    PSU: Thermaltake TT Toughpower 875W
    OS : Windows 8 Pro

    I can't upload my mini dumps, but I'll upload it later while I change my setting on Win8 first.

    Please take time to help me with this, I got enough errors for the day. :'(

    Thanks.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,731   +156

    If you use the on-board video do you still get BSOD's?
  3. TS-56336

    TS-56336 TechSpot Booster Topic Starter Posts: 571   +98

    Haven't tried yet. It's weird though, before formatting, Catalyst 13.1 leads me to my desktop and gets a balloon notification that saying "it has been recovered" when I try to open games. I haven't overclocked this thing. I bet it's hardware related.
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,731   +156

    Any yellow exclamation points in the device manager. They look like this (!)
  5. TS-56336

    TS-56336 TechSpot Booster Topic Starter Posts: 571   +98

    No exclamations. As of this moment, no blue screens, but I'll stick around to observe the system if more BSOD occurs. I am yet to try the on-board video and check if blue screens will kick again. I'll keep posting for updates. :)
  6. TS-56336

    TS-56336 TechSpot Booster Topic Starter Posts: 571   +98

    This post is now resolved. No blue screens in 24 hrs observations. Thanks
  7. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,731   +156

    Okay, thanks for the update:)


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.