TechSpot

Built in USB/SD Slots Don't Work

  1. Hi guys. I have an HP Compaq DX2400 (one of their business designed desktops).It's one of the models which has a build in set of UBB 2.0/SD/Micro SD slots etc., however only the USB 2.0 slot works. I can plug an SD card into the slot (not at the same time as anything being in the 2.0 slot) and the light which tells you it's registered an SD card shows up, but nothing on My Computer. (I'm using XP Professional)

    I've looked in Disk Management and when I plug in the SD card in to the slot it shows up, but it has no Drive letter. I have tried assigning a Drive Letter + Path to each slot, however when I try it comes out with the error "This operation did not complete because the partition or volume is not enabled. To enable the partition or volume, restart the computer"

    Now I've tried restarting several times, to no success. I've made sure the slots all have drivers (and they claim to)

    Can you help? I'm pretty much at the end of what I know.
     
  2. jobeard

    jobeard TS Ambassador Posts: 13,446   +323

    Check the settings for Autoplay in the Control Panel (at least Win/7 has it there).
    "using XP Professional" may need a registry hack . . .
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.