Can no longer save to flash drives

By macx
Sep 11, 2005
Topic Status:
Not open for further replies.
  1. I have 2 flash drives that I use between my home PC (98/SE)
    & a machine at work (I believe XP).

    For some time all was well, then all of a sudden first on 1 then later
    on the other, I can no longer save anything to them with either
    machine.

    I just read a post about a similar problem and have found out about
    "stopping" the device before unplugging it - I don't have that green
    arrow at the bottom on either computer - would they be hidden
    somehow and how to get them to show?

    Anyway, now that I know that, is there any way I can fix the problem?

    I can read and copy from them, so if I save all the files to my desktop,
    can I then reformat them or something to regain the save functionality?

    Thanks so much!
  2. macx

    macx TechSpot Maniac Topic Starter Posts: 743

    Yup, that worked.

    I copied all the files (successfully) into
    a folder on my hard drive, then deleted
    everything.

    Don't know if I needed to, but I ran
    Scandisk on the empty drive.

    Now I can save again! :approve:
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.