Can ping from router but unable to ping from client machines

By verve13
Sep 6, 2012
Post New Reply
  1. Hi All,
    I am having a weird issue with my Cisco 7200 router. From the router I am able to ping and reach out to the internet but from the client I am able to reach out to the internet but unable to ping [​IMG] I am not sure where is the issue but when I traceroute to it my packets are dropped at my routers interface. All my pings from the client time out. I checked the Access list to make sure ICMP is not blocked.
    Following is my running conf

    ip audit notify log
    ip audit po max-events 100
    ip ssh break-string ~
    ipv6 unicast-routing
    no ftp-server write-enable
    !
    no scripting tcl init
    no scripting tcl encdir

    !
    no voice hpi capture buffer
    no voice hpi capture destination

    !
    interface Loopback0
    description *** abc ***
    ip address 192.168.2.2 255.255.255.255
    !
    interface FastEthernet0/0
    description * Connection to officeswitch *
    ip address 10.0.2.1 255.255.255.240
    duplex full
    speed 100

    ipv6 rip abc enable
    no ipv6 mfib fast
    !
    interface FastEthernet0/1
    description * ISP1 *
    ip address 172.16.17.2 255.255.255.248
    ip access-group ISP1-IN in
    ip access-group ISP1-OUT out
    ip route-cache flow
    duplex full
    speed auto
    !
    interface Serial3/0
    description * ISP2 *
    ip address 10.23.21.2 255.255.255.252
    ip access-group Verio-IN in
    ip access-group Verio-OUT out
    ip route-cache flow
    serial restart-delay 0
    !
    interface Serial3/1
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial3/2
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial3/3
    no ip address
    shutdown
    serial restart-delay 0
    !
    router ospf 00000
    log-adjacency-changes
    network 192.168.0.0 0.0.31.255 area 0
    default-information originate
    !
    router bgp 00000
    no synchronization
    bgp log-neighbor-changes
    network 192.168.0.0.0 mask 255.255.224.0
    aggregate-address 192.168.0.0 255.255.224.0 summary-only
    no auto-summary
    !
    ip classless
    ip flow-export source Loopback0
    ip flow-export version 5
    ip flow-aggregation cache protocol-port
    enabled
    !
    ip flow-aggregation cache prefix
    enabled
    !
    no ip http server
    no ip http secure-server
    !
    ip as-path access-list 5 permit ^$
    ip as-path access-list 5 deny .*
    ip as-path access-list 10 permit ^$
    ip as-path access-list 20 permit ^00000

    ip as-path access-list 30 permit ^00000

    ip as-path access-list 30 permit ^00000

    ip as-path access-list 30 permit ^00000
    ip as-path access-list 30 permit ^00000
    !
    !
    ip access-list standard Access
    permit 192.168.0.0 0.0.31.255
    deny any log
    !
    ip access-list extended ISP1-IN
    permit tcp host 192.168.1.2 any eq www log
    permit icmp any any log
    deny ip 10.0.0.0 0.255.255.255 any log
    deny tcp any any eq ftp log
    deny tcp any any eq smtp log
    deny tcp any any eq 443 log
    deny ip 192.168.0.0 0.0.255.255 any log
    permit ip any any

    ip access-list extended ISP1-OUT
    permit icmp any any log
    permit ip any any

    ip access-list extended ISP2-IN
    permit icmp any any log
    deny ip 10.0.0.0 0.255.255.255 any log
    deny tcp any any eq ftp log
    deny tcp any any eq smtp log
    deny tcp any any eq 443
    deny ip 192.168.0.0 0.0.255.255 any log
    permit ip any any

    ip access-list extended ISP2-OUT
    permit ip any any
    permit icmp any any

    logging trap debugging
    logging source-interface Loopback0
    snmp-server community apricot RO 1
    snmp-server trap-source Loopback0
    snmp-server location 101 S Ellsworth Ave Suite 350
    snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
    snmp-server enable traps tty
    snmp-server enable traps config
    snmp-server enable traps envmon fan shutdown supply temperature
    snmp-server enable traps bgp
    redistribute static
    !
    !
    route-map ISP1PATH permit 5
    match as-path 30
    !
    route-map ISP1PATH permit 10
    match as-path 20
    set as-path prepend 00000
    !
    route-map SETPATH permit 10
    match as-path 10
    set as-path prepend 00001
    !


    I will appreciate any input to help me solve this problem.
  2. jobeard

    jobeard TS Ambassador Posts: 13,028   +221

    ping is not required to have connectivity - - it is only a test & traceroute tool.

    From the client, get a command prompt (or in Linux a Terminal) use nslookup google.com
    If it returns the IP address of google, then you can ignore the ping problem
  3. verve13

    verve13 Newcomer, in training Topic Starter

    Thanks for your reply. I understand Ping is not required for connectivity but its the quickest way to troubleshoot connectivity from client to internet. Plus you cant trace-route which provides the exact location of where the packages are dropping which helps in narrowing down the problem while troubleshooting. Do you see anything in my conf which might be blocking the ICMP(ping)?
  4. ImaBrokeDude

    ImaBrokeDude TechSpot Member Posts: 41

    Sometimes pings are blocked by the server side.
  5. jobeard

    jobeard TS Ambassador Posts: 13,028   +221

    Let's be clear;

    case A: client a <-->client b on your router should ping correctly and if not then the NIC or FW on those systems
    needs investigation.

    case B: client a -->ping or tracert to a website like google.com should work

    case C: ping from me to your router is configurable as to if you want your router to respond

    case D: ping from me to some client x attached to your router should always fail

    my tracert (the PC name) to techspot is attached

    Attached Files:

  6. ImaBrokeDude

    ImaBrokeDude TechSpot Member Posts: 41

    He said it all :)
  7. verve13

    verve13 Newcomer, in training Topic Starter

    All clients inside our LAN that is xyz.com can ping each other. (e.g. can ping from 192.168.1.1 <---> 192.168.1.255 or any IP in our IP block). But it fails if when I ping outside our IP block or domain (e.g. 192.168.1.1 --> 8.8.8.8 google public IP). I cant tracert/traceroute to ourside public IP's. We dont have a firewall just a couple of rules in access list which I have included in my post at the beginning. Hope I was able to elaborate this better. Thanks for replying!!
  8. ImaBrokeDude

    ImaBrokeDude TechSpot Member Posts: 41

    8.8.8.8 and 8.8.4.4 are the google DNS Servers, pings are blocked by these IP addresses.
  9. verve13

    verve13 Newcomer, in training Topic Starter

    Actually thats not true at all. Pings are never blocked to these as they are public DNS. You can verify this if you want to ;)
    Google DNS was just something I used as an example. I am unable to ping any public WAN IP to make it shorter. Any thoughts?
  10. ImaBrokeDude

    ImaBrokeDude TechSpot Member Posts: 41

    This might be due to your ISP or web filtering if such exists.
  11. jobeard

    jobeard TS Ambassador Posts: 13,028   +221

    Let's slow down a bit. Your problem is client ping/traceroute crossing the gateway router - -
    Both of these use the ICMP protocol (ie: not related to ports).

    ICMP is described here

    Your router/firewall needs to allow ICMP Type 8 (ping) and apparently Type 30.
    To allow error replies, also include Type 3.

    By carefully reading the Traceroute Protocol here, you can see what needs to be done.
  12. verve13

    verve13 Newcomer, in training Topic Starter

    We dont have a firewall and instead we use access lists to block the traffic. Currently I dont have any acess control rules applied may block ICMP traffic. any clue?
  13. jobeard

    jobeard TS Ambassador Posts: 13,028   +221

    Yes, I mentioned the FW to highlight components "of interest" to your problem.

    Your config looks good to me, but I'm not a Cisco guy. Perhaps this blog might give you some insight.
     
  14. verve13

    verve13 Newcomer, in training Topic Starter

    Thanks for your input. need to go through access list again.
  15. jobeard

    jobeard TS Ambassador Posts: 13,028   +221

    Btw: all those cfg rules are FIREWALL settings - - eg:
    deny tcp any any eq ftp log
    deny tcp any any eq smtp log
    deny tcp any any eq 443
  16. verve13

    verve13 Newcomer, in training Topic Starter

    Thanks you guys.. I figured out it required some changes in the access control list on both layer 3 server and router. seems to be working now :)
  17. jobeard

    jobeard TS Ambassador Posts: 13,028   +221

    Super. Why not share the new router config for those that might follow?


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.