TechSpot

Can see flash drive, but unable to access

By ziggym
Jan 30, 2011
Post New Reply
  1. Hi there,

    HELP! I did read the Flash drive recovery post and it's not looking good for me but would like some input if anyone can help....

    The issue: Using a 8gb USB flash drive and I'm unable to access the files. I am able to see it as a removable device - however the name is now "removable device" as opposed to the actual name - I can see in the properties the storage capacity and what is left - but it says "this folder is empty"?

    Did I somehow screw this thing up? Is there a way to get my files back?

    I get the same result when I plug it into any computer.

    Any suggestions would be greatly appreciated!

    Regards,
    z
     
  2. Punkid

    Punkid TS Guru Posts: 419

  3. mailpup

    mailpup TS Special Forces Posts: 6,918   +345

    Keep in mind that if you format the drive, you will lose any files on it.
     
  4. ramblingpariah

    ramblingpariah TS Rookie

    Same

    I've got a 32gb Sony Microvault, doing all the same. I've tried HP's utilities, Sandisk, Partition Assistant...the list goes on and on. Windows 7 (ultimate 64, if it helps) sees the drive, but even with admin privileges, I can't do anything to the drive - it seems like it lost its partition, but there's nothing I can do to get it back. "Can't open volume for direct access." I don't even care about the files on it, I'd just like to get more than a month of use out of my little drive.
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...