1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Cannot associate Editplus with .txt files

By nwyllie ยท 5 replies
Jan 18, 2009
  1. I've had EditPlus as my default program for .txt files for years. At some time recently the association has been lost and I have attempted to re-associate program and file type, but the association will not take. I go to folder options, file types tab, scroll down and select TXT. I select change and I get the pop-up listing suggestions; EditPlus is not on the list. So I choose browse and find the program, click open, and the program is still not on the list.

    I upgraded Editplus after first noting this issue and was able to make the association but it soon became lost again and nothing I've tried will re-establish it.

    I'm running XP SP3 with all security updates. I have Avast! for anti virus, Sygate for a firewall, and also run Spyware Doctor (free versions of all). I run the same thing on two other machines and the association is fine. I'd be grateful for any suggestions.
     
  2. nobardin

    nobardin TS Rookie Posts: 256

    In editplus:

    1 Go to Tools / Preferences... / Files / Settings & syntax.

    2 Select the File type for which you want EditPlus to be your default editor (like Text, PHP).

    3 Make sure that the extension you want to associate with EditPlus is listed in the File extensions field. Multiple extensions for the same file type are separated by a semicolon (";"). Example: php;php3;php4;inc.

    4 Check the Association by looking at a text file.

    Hope this helps.
     
  3. gbhall

    gbhall TechSpot Chancellor Posts: 2,432   +77

    One would normally re-establish associations by re-installing the program, but I gather you have already done that.

    Have a look in the registry under Hkey_Classes_root for the key ".txt".
    What is the program description under '(default)' ? (normally notepad.txt I think)
    What is under the key 'openWithProgIDs' ? (This gives you the list of programs that might open it - what you see when you browse for a file in Windows explorer, and hold down the shift key while pressing enter - not double clicking!! - a .txt file name)
     
  4. nwyllie

    nwyllie TS Enthusiast Topic Starter Posts: 47

    I'd forgotten to look there but all seemed in order. Thanks for the suggestion and reminder :)
     
  5. nwyllie

    nwyllie TS Enthusiast Topic Starter Posts: 47

    I'd not tried a total uninstall and re-install (I really hate having to do that and loose settings). I installed the update mentioned over the existing install. I've un-installed and re-installed and the association is back, but I had that before with the update and it got lost again. If I loose it again I'll check the registry.

    Thanks.
     
  6. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Go to folder options, file types tab, scroll down and select TXT.

    Delete it.

    Reboot. Click on a txt file and set your preference.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...