TechSpot

cannot connect to the internet on windows xp

By confused001
Jun 27, 2006
Topic Status:
Not open for further replies.
  1. hello, i think this is the right place.
    i have a problem with my internet connection. I am using windows XP, and zone alarm as my firewall, and my antivirus. I also use mozilla and internet explorer for my web browsers. My internet connection does not work on the operating system. it worked before, i told zone alarm to ask if several win32 programs could go on the internet. Now, i tried allowing them, but they still do not work. Anyone who could help me? plyz.
  2. Peddant

    Peddant TS Rookie Posts: 1,644

    1.Make sure "Generic Host processs for Win32 services" has two ticks in
    Zone Alarm.You have ro restart the computer before that particular
    program will reconnect.(It`s DNS related)

    2.Have you run any anti-spyware programs recently ?
    Sometimes the removal of spyware can damage the Winsock chain.
    for which the fix is HERE
  3. confused001

    confused001 TS Rookie Topic Starter Posts: 142

    I tried what you told me, but both of them do not work.
    I even tried reinstalling the program, and it still does not work.
    I tried installing a different internet security suite, and it also does not work.
    Any sugestions.
  4. tipstir

    tipstir TS Ambassador Posts: 4,658   +82

    How do you connect to internet? If you have a network card. Un-install it and reboot the PC. Let Windows XP re-install the card driver. Once that's done.

    click on start
    click on run
    type: cmd
    click okay
    type: ipconfig /all > c:\my_isp_connect.txt
    type exit then enter

    click on start
    click on run
    type: c:\my_isp_connect.txt
    click okay

    Now notepad will open and you'll see what's going. Also if you want, go back to:

    click on start
    click on run
    type: cmd
    click okay
    type: ping www.google.com see if you can ping that... If you can't then you might have a corrupted socket.

    Do you have a Router?
  5. confused001

    confused001 TS Rookie Topic Starter Posts: 142

    Okay tipstir,
    This problem is only isolated to my windows xp, I Am currently dual booting with windows ME. I use the windows ME to go on the internet. This makes it very inconvienient, becasue i need to restart the computer to go on the internet, and I want it to work, so i do not need to go through all of this. I also have zone alarm working on my Windows ME, and it works fine.
    So i am positive that my thingy does work.

    PS: What is a socket?
    Also: Try responding to my other problem.
  6. confused001

    confused001 TS Rookie Topic Starter Posts: 142

    Pedimont,
    I cann't download the patch.
  7. N3051M

    N3051M TS Rookie Posts: 2,800

    how are you connecting to the internet? by dailup or broadband/router etc?

    Winxp uses sockets as something to do with their networking ability. Winsock is the term.. if you cant download it using pendant's link, then try googling for it, something like winsock repair etc...

    Try tipster's advice, and post that text file here, so we can have a look, and also what it says about the ping - ok or not.
  8. confused001

    confused001 TS Rookie Topic Starter Posts: 142

    Isp connect.txt

    sorry for taking very long.
    I cann't ping the server! :( I wonder what is wrong.
    I got the my isp connect.txt file attached.
    Plyz try and help me.
    Thanks

    Attached Files:

  9. N3051M

    N3051M TS Rookie Posts: 2,800

    Good starting point.. the .txt file.

    Now you need to answer some other questions:
    -How are you going to the internet? broadband modem, router, wifi, dailup?
    -do you or have you previously had Norton Internet Security installed?
    -what other addresses have you tried to ping?
    -assuming you use the ethernet port to conect to a device to go to the net, have you tried installing the latest drivers for the network card?
    -assuming you use dailup, or USB modems do you have the latest modem driver, or tried rolling back to the previous one?

    try pinging:
    10.0.0.1
    192.168.0.1
    127.0.0.0
    www.google.com
  10. Samstoned

    Samstoned TechSpot Paladin Posts: 2,582

    I would uninstall ZA
    can try to use services to disable the ZA service program
    then disable ZA on boot reboot uninstall
    check Za for adding default gateway router ip trusted zone
  11. confused001

    confused001 TS Rookie Topic Starter Posts: 142

    1. I am connecting to the internet through a broadband modem.
    2. No I have not had norton internet security installed, ever in my system. it is cleaned from any norton related materials.
    3. I have tried to ping the adderesses that you had posted, and i have also tried pinging the google adress. Everytime that i ping it, it says that there were 4 packages that were lost (lost 100%).
    4. I have not tried installing the latest drivers for my ethernet card.

    I don't get what samstoned is trying to say to me.
    Can anyone put it in more readable language for me. ty
     
  12. N3051M

    N3051M TS Rookie Posts: 2,800

    Samstoned trying to say either uninstall Zone alarm altogether, or disable Zonealarm from startup and the services page then uninstall. The last sentance he said was to check the settings on Zonealarm to see if you allowed the gateway to the internet..

    try updating your drivers first, then restart the pc. Run your internet connection wizard again throught the cd you got from your ISP. If that still doesnt work then download and run this (link courtousy from pendant :))
    http://www.softpedia.com/get/Tweak/Network-Tweak/WinSockFix.shtml
  13. confused001

    confused001 TS Rookie Topic Starter Posts: 142

    I tried updating the drivers, but could not find any drivers for my ethernet card.
    I do not have a cd from my isp, but i ran the Internet connection wizard, and it still does not work.
    I have another problem that has arrived. I disabled zonealarm, but i also left my other antivirus on. Everytime i connect to the internet with IE, or FireFox, it says that there are invalid packet headers.
    Got a solution to this? Think this may be the problem?

    I will try the winsock fix again.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.